Lina DAC won't power on

I have been using my Lina stack for a week or two and am loving it. Having a sad / scary issue today, however.

Last night, I powered the stack off using the power button on the amplifier (and the others via PowerLink). This morning, I went to turn it back on and only the amplifier and master clock powered on. No sign of life from the DAC.

The fuses in the DAC both look good, but I swapped them anyway. No change. I swapped the power cables, as well as the plugs on my UPS / surge protector, just in case. No change.

Any suggestions? It did seem like the original power-on for the DAC, when I unboxed the system, took longer than the other two units, but I have waited quite a while today and it just seems dead. No ethernet lights, no changes on the front of the unit… PowerLink, which is routed through the DAC to both of the other units, still works, however, but I imagine those ports bypass most of the DAC’s internals, allowing PowerLink to work even if one unit has failed.

Any help you can provide would be appreciated.

Hi Dan,

I am sorry to read about this. Did you try to power cycle your Lina DAC, by switching it off by the rocker switch on its back, wait a minute or two, and switch it back on?

Yes I have. And I just gave it a five minute wait to be sure, no luck.

Thanks for your reply.

Hi Dan,

I think it is best to report your problem to [email protected]

This way it will be fed into the official ticketing system at dCS, and will get their attention.

That was my first stop. Was just hoping I had missed something obvious that this forum would know about.

As a last resort, I would remove the Power Link from the back of your DAC, try to reboot it again from the switch at the back, wait, and switch on again from the back, and from its power button under the front. If still no luck you will need help, of your dealer, and/ or dCS.

Unfortunately, I have everything disconnected except power, so I guess this is in dcs’s hands.

Well, this is perplexing.

The only way it will turn on is if I hold the power button while flipping the power switch from Off to On. At least I can use it, and have something useful to tell the support team!

The power button also works to put it into sleep mode, or turn it off, once it is on.

2 Likes

Please keep us posted on how this got solved.

Hi, all I had a similar problem yesterday. I came back to it several hours later after doing all the other steps mentioned here and it powered on. I am a little concerned as my very first Lina Dac had to be replaced in the first couple of weeks owning it as the screen went all grayed out. DCS was terrific and replaced it immediately. I am just concerned about this piece hearing your issue as well… Are there other issues out there with the DAC? Boy I sure hope not love this set up and enjoy it daily would hate to hear of issues like this .???

Hi, today I have the exact same issue for the second time. A back in August my DAC screen went grayed out and I had to have the unit replaced. This system is too much of an investment to be having to be dealing with issues like this so soon it’s just months old???scared stiff we have an issue here? Im contacting DCS now

Hi Anthony,

I’m really sorry to hear you are experiencing this issue. I have responded to your email so we can get this sorted for you ASAP.