iPad loses connection to Bartok

I’m a fairly new owner and user of the Bartok, so forgive me if this has been covered but I couldn’t find anything.
I have a new iPad which is more or less dedicated to controlling the Bartok. I tend to stop what I’m listening to when I’ve had enough and leave everything powered on as I always did in the past with my previous streamer, a Linn Akurate which worked fine.The problem is that when I return to play something the iPad has lost connection to the Bartok and I end up messing about powering off the Bartok (using the front power button) and/or closing and reloading the mosaic app before it reconnects wasting 5+ minutes every time.
What am I doing wrong? I have super fast broadband (350mb) and all software is up to date. The Bartok is connected to anNaim 282 preamp. Thanks for any advice

2 Likes

This kind of problem is usually down to network rather than the network player. I have suffered this problem very occasionally and suspect my router as other devices also drop out from time to time albeit infrequently. If course a temporary solution is easy and quick, just close the app and reopen it ( not necessarily a need to close Bartok too).

One thing that may prevent a more full answer today is that iOS was updated 3 days ago to v.13.5 which is generating many reports of application failure in one way or another. Worth checking to see what iOS version you have.

Thanks for your reply. I’m not sure it is the network. My network is very stable and the app worked instantly on my iPhone - it is just the app on my iPad that plays up.

Just moved from Galaxy Tab S4 to IPad Pro and not noticed any problems even with IOS 13.5 installed. I do find that my BlueMail app stalls and has to be restarted to work again so suspect that there is something somewhere that drops server or network connections from time to time. Pretty sure though that Bartok/Mosaic is not the problem.

Which more or less establishes that the problem you have is neither Bartok nor Mosaic app originated. If it was then your iPhone would also produce the same result.

Your iPad is new so I would check that you have configured it correctly, it being unfamiliar to you. At least reinstall the Mosaic app from App Store.

Nick, more often than not the problem has to do with the iPad/iOS disconnecting from your WiFi network when it locks from inactivity; iOS is kind of all over the place across versions on how WiFi works exactly.

Assuming your home WiFi network isn’t the issue, one recommendation is to turn OFF “Auto-Lock” (Settings -> Battery -> Auto-Lock -> Never), and just explicitly turn off the iPad only when you’re no longer listening. That worked for me in the past when I had similar issues.

There are other settings that seem to be required in some instances, for example, Privacy -> Location Services -> System Services -> Networking & Wireless to OFF, but I haven’t personally had to do any of that with iOS 13.5 (or prior).

Good luck :crossed_fingers:t3: and let us know how it goes.

Hi all,

Just to head this one off, as I am seeing multiple threads emerging around the same topic. iOS devices running the new 13.5 update seem to be experiencing a range of different issues. These are happening across a large range of apps and is not specific to Mosaic.

If you are using an iOS device that has been updated to iOS 13.5 and are now experiencing Mosaic connectivity issues (Mosaic not discovering the dCS device or losing connection to it) or problems opening the app itself, try uninstalling and reinstalling Mosaic.

Should this not resolve the issues you are seeing, my current understanding is that this issue will be resolved in a future release / patch of iOS should the issues have started after updating .

If you have been experiencing connectivity issues since before updating to iOS 13.5, take a look at the FAQ on this here:

Yeah I can confirm that happened to me too.

Thanks but I’m very familiar with iPads. The iPad version of the mosaic app could have an issue that may not manifest in the iPhone version, no?

AFAIK they are identical.

Thanks for your suggestions. Just FYI auto lock is in display & brightness