Ipad and iphone will not connect with Vivaldi One

Hello = Mosaic has been working fine with occasional needs to reboot my Vivaldi One or uninstall and reinstall Mosaic to facilitate a re-connection. I recently changed my ATT router out for an Edge Router ER-X SFP (with ATT certs installed) and have ethernet connections from my M12 Gold switch to Roon Nucleus, Vivaldi One, and Edge Router ER-X. Now my ipad or iphone will not connect (using the Mosaic app) with my V-One. I get the endlessly spinning blue circle and the readout saying, “looking for devices.” Any help would be greatly appreciated!
Michael

Surely your router connects to your switch and not vice versa? Sorry but your description is a bit ambiguous and implies that the connection is from the M12 switch to the router. Then again, what do I know?

Michael, is that the Ubiquity EdgeRouter X SFP? Your iPhone/iPad must be connecting via a WiFi Access Point, how’s that WiFi Access Point connected to there rest of you network (presumably to one of the EdgeRouter ports?).

I would start with the basic;

  • Is the EdgeRouter your main DHCP server for your home? (presumably with NAT/Firewall facing the Internet)
  • Does your VivaldiOne pick up a valid IP address?
  • Are the iPhone/iPad’s IP addresses within that same subnet?
  • What about with a PC/Laptop, are you able to use a browser to access the VivaldiOne?

Start with those, and I’m sure you’ll soon discover where the issue is :crossed_fingers:t3:

Let me clarify, Pete. I have an ATT fibre optic ONT which has an ethernet cable going from it to the ER-X SFP. From my M12 Gold switch I have three ethernet cables, one connects with the ER-X SFP, one goes to the Roon Nucleus, and one goes to my Vivaldi One. Up until now I’ve only had minor connection issues. Thanks and I’d love to hear what you know!
Michael

Faced with such a direct question I have to answer " Very little". I was going to suggest that with hope Anupc would answer. But he now has so I think what he suggests would be best to be getting on with.

Thanks for your help, Anupc!

“Is the EdgeRouter your main DHCP server for your home? (presumably with NAT/Firewall facing the Internet)”

Yes and the firewall is in default setting.

“Does your Vivaldi One pick up a valid IP address? Are the iPhone/iPad’s IP addresses within that same subnet?”

How do I find the answer to these questions?

“What about with a PC/Laptop, are you able to use a browser to access the Vivaldi One?”

I am able to enter the dCS IP address and access Main Page, Device Settings, and Network Settings. Is that what you mean?

Thanks, Michael

Right, so there’s no problem with your V-One as far as having a proper IP address.

What about the iPhone/iPad, they’re presumably connected via a WiFi Access Point yes? What is that Access point, and where is it connected to?

ps: Where was your PC/Laptop connected when you successfully accessed the V-One?

I’m using a Ubiquiti Wireless router connected to the ER-X via ethernet. My laptop is signed in to the wireless network…

as is my iphone and ipad…

I’m guessing that’s probably where your problem is.

For things to work properly, your V-One and iPhone/iPad need to typically all be in the same IP subnet, for example they all have a 192.168.2.x address where only the “x” varies across devices.

So you want to check the IP addresses of each device (from iOS -> Settings -> WiFi -> (Info))

So, my Vivaldi IP address is 192.168.2.x but the IP address for the ipad and iphone are 192.168.xxx.xxx and 192.168.yyy.yyy. Do I manually change each one’s IP address? If so, would I have each one start with 192.168.2. and enter random number or numbers after “2.”?

Right, as I suspected. Your Ubiquiti WiFi Access Point has NAT (and DHCP) turned on. Thats where the problem is. Whats’ the model?

That WiFi Access Point needs to be reconfigured to be a pure WiFi bridge only, with no NAT, no DHCP ( and no Firewalls if thats turned on- you don’t need that since all traffic in/out of that Access Point it is entirely within your home network).

1 Like

Purchased With:

\ 150x125

Ubiquiti - AmpliFi Dual-Band Mesh Wi-Fi System - White

Are you able to walk me through that process?

Pull down the Manual (if you don’t already have it).

Ideally, reconfigure the WiFi AP using your iPhone and the AmpliFi App via Bluetooth (I assume thats how your configured it in the first place?)

In “Chapter 6: System” (page 19 and after) where the manual talks about the “Router Settings” -> “Network Type”; thats where you’re going to change settings. Follow through to page 21 (under the DHCP heading).

Via the AmpliFi App connect to the Access Point. Under the “Network Type” setting, which should currently be configured DHCP, you need to additionally enable [Bridge Mode] (mentioned at the bottom-right of page 21 in the manual). Not sure if the AP needs a quick reboot after the reconfiguration, probably a good idea.

That should fix it :crossed_fingers:t4: :grin:

Thank you, I’ll give this a try and let you know how it goes! BTW, I used my ipad for set up.

Problem is solved!, Thank you for riding this tiger with me, Anupc! As I am a very non-tech person by both nature and nurture I am a bit stunned I was able to follow your direction and get this dialed in. Again, I’m very grateful for your help and it’s reassuring to know there are highly knowledgeable people in the dCS community willing to assist those of us who are tech challenged…
All the Best, Michael

1 Like

Glad to hear it! :smiley:

The configuration change you made actually solves other problems for you. For example, you would have had issues with a Roon Control point over WiFi; it should work just fine now. Likewise any other app that depends on Multicast packets, like discovering a UPnP server from your WiFi connected Laptop for example, that’ll now work perfectly.

By the way to your first post in this thread; generally speaking you shouldn’t need to reinstall Mosaic or reboot your V-One; having to do either is usually a symptom of something else wrong with your network.

1 Like

Thank you, Anupc, so appreciate your help!