Install problem USB driver Vivaldi DAC

Yesterday received and connected my new Vivaldi DAC :grinning:.
My Fanless PC with JCat network card and USB card connected to the 2.0 USB input and everything worked fine right away.
Roon also immediately recognized the DAC and plays all formats well.
So Windows 10 Pro automatically recognized and installed the Vivaldi DAC.

But when I look at in my PC by the “device manager”, I see that there is an error message:
The drivers for this device are not installed (code 28)

So I installed the dCS driver as stated in the manual but the error message remains.
What can that be?

(I know Ruud - I’ve got his old Rossini :sunglasses: )

I see that the audio path does recognise the audio-class 2 device, and I assume you get sound out of the DAC. It even reports the correct name. So far so good.

I’m suspecting that what you see in “Other Devices” is not the audio part of the Vivaldi, but another device on the same USB bus for some other purpose. “DFU” could mean Device Firmware Utility, but I’m guessing here. Contrary to Rossini, since Vivaldi DAC does not have a network connection, firmware updates have to be done through the USB port so there must be a path inside the equipment to enable that - that’s my guess.

I don’t have a Vivaldi DAC in front of me currently, but I’m guessing that this is partially due to MQA support in the DAC. We’re required to present an additional interface via USB that the player can query in order to find out MQA capabilities and get MQA status. It presents as an HID device. I’m wondering if on first connection Windows didn’t recognize it and that didn’t get overridden when you installed the dCS driver.

You could try uninstalling the dCS driver and deleting the device in device manager. Pull the USB cable, then install the dCS driver. That might get it going correctly.

Regardless, this has no impact on playback so unless it causes concern I’d just queue up another track and enjoy it :wink:

I installed the driver without connecting the cable and now it is perfect.
Thanks Andrew and also Paul (that Rossini guy, ha ha)

1 Like