How to stream Idagio from Windows PC to dCS Upsampler

I’m very happily playing music on my Vivaldi Upsampler/DAC from Roon running on Windows 10 PC. I would like to stream music from the Idagio music service, too. Any tips on where to start? The Upsampler manual talks only about using USB to stream to the Upsampler, but it doesn’t offer details about what software to use on the PC. (And I’d prefer to stream via ethernet rather than USB.)

Looks like Apple Air Play would work.

So long as the OP has an Apple device to run the Idagio Mac only downloaded player on. No way can he do it on his Windows machine.

I’ve no Apple devices.

Basically without a Mac it is not for you unless you do not care about gapless with classical music and are happy with uSB. There is an Android player download but that is not obviously compatible with your dCS equipment.

Do you live in a country where Qobuz is not available as that would be the obvious choice otherwise for a classical music enthusiast ?

iPad is one of the best values in the history of Western civilization.

I live in the US, and Qobuz is available here. In fact, I have a subscription and use Qobuz from time to time through Roon.

But I’d heard some good things about the music selections at Idagio, and I have a trial subscription. That’s the basis of my inquriy.

Checking their website, there is a Windows app download as well:

I am not a subscriber to their service, so I’ve no idea how well it works. I’d guess you probably have to use it connected via USB to your dCS,

Yes, I will be exploring that. Thanks.

How odd!. When I Google Idagio I get this page and there is no mention of a Windows player:

Go to The Ultimate Classical Music Streaming App | IDAGIO | IDAGIO, click on the 3 bars in the upper right, then click on ‘download app’.

I clicked your link and no Windows download there either after clicking the 3 bars :

Mind you I don’t quite know why I am responding as it isn’t me that is interested in Idagio especially as I cannot see that it offers anything that Qobuz doesn’t however Qobuz does offer things that Idagio doesn’t ( like hi-res).

Turns out the choice of download app is available only if one is logged in to the site.

Thanks James. That is a crazy way to do business. Had you not alerted me and were I interested then I would have just passed on being a Windows user.

Back to the real problem. I’ve used the Mosaic app on my Android phone to set Audio to USB/PC and to set Device to USB class 2. And I’ve connected my Windows 10 Pro x64 PC to the Upsampler via its USB2 port. I tried playing things via the Idagio app (which I installed on the PC), and in fact the Windows Sound applet shows Remote Audio as the sole audio device, and the applet’s volume bar shows activity. But nothing comes out of the Upsampler, and in the Mosaic Audio Source window nothing shows playing (if I am using Network, the Audio Source window shows what’s playing at the bottom.

So how are things supposed to be set up? The Upsampler manual is silent on this point (it does describe how to play from, say, a thumb drive inserted in the USB1 socket on the Upsampler).

Strangely, it looks like the Idagio App on Windows/Mac does not yet support playback over USB!? :thinking:


Hmm … In any case, I’ve tried playing music from the Idagio website in Windows Edge, with no luck.

Right now I’d settle for a proof of concept that music can be sent to the Upsampler by Windows over a USB cable.

I just tested the Idagio App on my Macbook.

So, while the App itself doesn’t seem to support redirecting the audio to the USB port, I can switch my MacOS “speaker” to my dCS DAC instead. When thats done, the Idagio App output does work over USB to my dCS DAC.

Not sure what the equivalent on Windows is, but it should be doable. So, you’ve got a Windows/PC settings issue, nothing to do with dCS (which should just accept whatever comes over USB).

I agree that this looks like a purely Windows issue.

James. Firstly you need to download the dCS windows USB class 2 driver from here:

After installing this go to your Windows settings : system/sound/speakers/properties. With your dCS device attached by the USB cable you should be able to select it as the default device . You then need to select the advanced tab and set the sample rate to 16/44.1 for Idagio. BTW if you use another source via USB you may need to change this setting to match incoming every time the data resolution changes or Windows will up or down sample it to the rate pre-set in this setting, Then check the " Exclusive Mode" boxes or your music will be interrupted by Windows Sounds when the computer is performing other tasks in the background e.g. email receipt.

Navigating to the above selection is difficult with the current Win10 layout of the settings options. YOu may find it easier if you enter “Control Panel” in the Windows search bar , choose Hardware and Sound and proceed as above.

NB: In regard to changing the settings each time the resolution alters see if the Idagio desktop player allows you to select an ASIO or WASAPI session, probably in a “speakers” or “output device” or some similar wording option. If you can then the music data stream from Idagio will bypass the Windows sound mixer and a bit perfect stream will be delivered to the dCS DAC.

BTW, once you have done the above then that is only the beginning of getting good sound from USB. You will need to find a way of diminishing the parasitic noise from the computer itself which is transmitted by the USB interface including via the 5V power bus so you should look at one of the many USB conditioners out there. The choice of USB cable will also have a lot of impact on the sound that you enjoy.