FPGA upgrade stuck?

Hi, been away from my system from several months, and decided I needed to check versions on a few devices including my Rossini. App version 1.4.0 (143), Front Panel 2.03, Control Board 2.03, Network Board 1.3.0 (509). I think it said it was going to update to 2.04, which started ok, but then told me to recycle the Rossini, which I did, it rebooted fine, and was playing music again. I noticed the version wasn’t updated, or at least it it had the 2.04 update to install.

I restarted the update process through Mosaic, and I’m getting the “FGPA update started…Image verified. Performing update. Verifying update”. I think perhaps it’s scrolling some of the update statuses and the FGPA update is the current step it seems “stuck” on? It’s been in this state for over 12 hours now, the front panel and buttons are not responsive. However Roon still sees it as does Mosaic and the odd thing is that it will still play music. I was not playing music when started the update.

Do I just keep waiting? I am very hesitant to reboot power due to the fact that powering down something during an update is usually a terrible idea.

Help please?

Hi Jay and welcome to the community forum which I hope you are going to find useful and informative.
There are a couple of issues here, one really for dCS themselves and what I hope will be some help for you.

Firstly II hope that Phil at dCS picks up on this as I am trying to tag him at Support but the forum software does not seem to be doing this after use of the @ symbol. Anyway the point is that the Software Update record for the Rossini control panel on the dCS web pages seems to stop at v.2.01 and looks as if it needs updating. I expect that the updater finding v.2.04 will be correct.

Now to your precise issue. When performing an online update it is first necessary to reset the unit or the update is likely to fail - as seems to be the case here. You do this before attempting the update installation by switching off the unit using the switch on the rear panel. Wait a few minutes then switch back on and proceed with Mosaic carrying out the update sequence. You may need to manually switch off and back on again at the end though sometimes this will occur automatically. Just keep an eye of the messages on the display.

So I will risk things :thinking: by advising that you abandon what you have got now, switch off as above and start again.

1 Like

This has happened to me a couple of times. I rebooted the unit and the update was successful.

Tried 4 times, including leaving it off for an hour. Seemed like it worked once on the third try in the middle, but never updated.

Now when I try to boot it I’m getting a bootloader error…first saying it couldn’t read from the SD card (is there an SD card? I don’t see a slot?).

Not good. Is it bricked now?

There is no SD card AFAIK.

If you followed the instruction I gave earlier it should have updated. Further the update system ensures that the earlier version is held in memory so that if there is a failed update the unit will revert to that version.

I can’t understand what is happening but taking your posts at face value there seems to be a fault and I would recommend that you raise the issue initially with your dealer. That is what he is there for.

1 Like

I did what you suggested and it looks like that is what is in the manual as well. It failed a few more times, then it looked like it was working and It restarted itself after some time, but now has resulted in it not booting. I’ll have to try to contact my dealer…I bought it remotely from one.

Jay, let us know how you get on.

1 Like

I’ve emailed them. Sunday night here, will see if they respond tomorrow during business hours. dCS not listed on their site any longer, so perhaps they are no longer a dealer.

Thanks Jay. Keep us up to date ( hopefully tomorrow). The dealer should be the first point able to help. Yes, the dealer list currently on the dCS website is unreliable IMO offering, for some countries, only the local distributor.

Don’t worry you will find the support you need if we need to go further.

1 Like

Appreciate your help! ty.

That sounds like trouble. But once I had to reboot about 4 times to get the upgrade unstuck and properly installed. Maybe try unplugging the power cable for a bit and rebooting again.

1 Like

Hi Jay,

If you can contact us on [email protected] then we can try to work the issue through with you and if necessary get you in contact with the most appropriate dealer to get you back up and running again…

Best regards

Phil Harris


My dealer has been great but we do not have it resolved unfortunately, and sending it in to be re-flashed is apparently a $600 minimum charge to fix what I don’t think was anything I did wrong. Disappointing for a $25K piece of hardware.

I will add I appreciate folks on this forum who did care and tried to help me resolve it.

Thanks Jay. I am sorry to learn that it hasn’t been resolved. I don’t think that anything implies that the fault is somehow to do with any action that you did.

The machine seems to be faulty in some way and I am assuming from your post that it is out of the warranty period. Like any product outside of this period repairs are then chargeable. In this case there is a minimum charge but remember that these are expensive items in the first place and that labour and parts are going to reflect this.

1 Like

Jay, I’m curious what that error message looks like. :thinking: Any chance you could post a picture for us to see?

1 Like

Again, I want to say I’m sincerely thankful for folks trying help here and appreciate where dCS is in the situation. I don’t agree with the points, however.

I don’t think the machine is faulty. The software update script should have worked, I’m sorry. I’m in the software industry. Updating the OS or more importantly firmware is not only a good practice, it’s a necessary requirement and has been for over 15 years (or longer) in this hardware business. The fact that the site doesn’t seem to have current release notes is also a reflection on the approach, I’m sorry to say. This is a network attached device and creating and testing resilient update scripts that work and have fail-safes is really important. Having other ways to flash without putting a $25K device in the mail also seems really important.

Coincidentally my wife’s iphone was literally bricked last week with an overnight software update that failed…it was flashed the next day for free even though we expected it was dead and we’d need to buy a new one. And I’m very aware of Apple’s policies and approach on obsolescence of hardware, which thankfully are far from what I perceive to be the dCS policy.

I’m genuinely appreciative that dCS wants to maintain my product, keep it up to date, etc. I’m appreciative that they will allow me to purchase the Apex update vs. making me sell my current unit and pay full retail for the updated version. If the error in the script failed somewhere trying to “read an SD card,” then reading from a card/drive to boot shouldn’t be a $600 flash regardless of how expensive tech time is. There are USB ports so helping the customer bypass startup scripts (with a computer or thumb drive or whatever) in order to flash remotely should be a core part of the unit’s software.

Additionally, having had a number of very expensive pieces of stereo equipment damaged in shipping in the last 5 years, I don’t want to send my very, very expensive unit in for service to get it back to use for a few weeks or months only to turn around and send it back to the same place to get the Apex a month or two or three later. That seems a lot more risky and cost-prohibitive than a firmware update.

Sorry for the rant. Still disappointed.

@anup Here’s what happens on bootup. Somehow it appears to see an update file which I’m guessing is corrupt and causes the update to abort.


Thanks Jay, much appreciated :+1:t2:.

I’m sure dCS will make you whole, but I do agree the supposed cost involved in getting this fixed seems rather steep under the circumstances. By the way, a corrupted boot flash will require internal access though, so labour will be involved, and can’t be done remotely AFAIK.

1 Like

Yep, thanks again for the thoughts.

Sadly I’ve had my PS Audio dac and one of my SOTM units freeze up over the years…both of which were able to be revived through SD card recoveries. While not the same, Antipodes tech folk have logged in and helped me complete a failed software update (that didn’t brick the unit, so it was still online for them to access–so not the same, I know). I’m also keenly aware that there are 100s of millions of iphones and probably only 100s of Rossinis floating around.

I would be very surprised if dCS did not fix the unit at no charge. It sure doesn’t sound like you did anything wrong.