Firmware update fails

I installed Mosaic 1.1.1 on my iPad. But when I go to support and try to update the firmware (2 items), they download but fail the checksum step every time. What do I do?

And I am disappointed that the new Mosaic does not have an easier way to adjust volume. Like a +/1 sign. It is really hard to get my iPad to acknowledge finger taps, and if it does, when I remove my finger, the selected volume changes. Furthermore, if the volume is all the way up, it is essentially impossible to change it.

Hello James,

Have you tried switching off the Bartók (really off, switch at the back), waiting a few seconds, turning it back on and wait for network connectivity to come back and retry the update then?

It seems to have solved the issue for several others here.

1 Like

Skywatcher is correct. You need to reboot your dCS component before installing the update.

I too had hoped that the thermometer style volume control could have been replaced with something that is ergonomically better. However your remark:

suggests that you have an issue with your i-pad , not with Mosaic. Have you changed the touch sensitivity of your i-pads’ screen to suit you? To do this on the i-pad go to; Settings/Accessibility/Touch.


The reboot before update fixed it, but Bartok did not reboot automatically.
The sensitivity of the touch screen is too low perhaps since often my taps are ignored in Mosaic. Not having headphone jack, I see nothing new. It is still really difficult to find an artist by scrolling the list (thousands long), hard to adjust volume, and often I end up being unable to back up to where I was.

What UPnP server software do you use? It should be MinimServer. With MinimServer you can set it to display in many ways ( using MinimWatch). For example not just album title A-Z but to only display artists whose name begins with e.g. H or W etc. Or by year of release. Or by composer etc. etc. Mosaic only displays what the server software makes available.

Hi I have tried to update le Bartok.
First time I had to manually switch off the unit, after 12 hours the update was still in progress.

Then I have tried again.
Now after a few minutes I get on the screen CHECKSUM.
How long I have to wait?

That should not be happening. You say that you switched off the unit but it isn’t clear when you did this in the process.

Switch off Bartok from the power switch on the rear panel. Wait a minute or two. Now try the update again.

I switched off after 12 hours of update in progress.