Failed to load Metadata

When I ask Mosaic to show me album information I get

Is this me or does everyone get this… and, before I get asked I’m using Asset :wink:

Was this onr

Was this one of those odd occasional glitches that just happens with computers ( digital audio processors being a specialised variety) or does it occur whenever you use Mosaic?

As you probably know I am going to remind you that dCS does not support UPnP sever software other than MinimServer.


onr ?

I’ve tried a dozen different albums and they all report this issue. I know I use Asset but I was just checking I wasn’t doing anything wrong - other than using Asset that is! :wink:

There have been reports of odd things happening when using UPnP servers other than MinimServer so that as a cause remains open.

However this sounds to me more like one of those things that just sometimes happens. If Mosaic/Asset is not retrieving the metadata for for album then it is likely to do so if you choose another during the same session. I would simply close Mosaic ( I mean close it , not just switch of the phone or tablet you are running it on as it may reopen with the same having saved it.). You may need to reboot Bartok too from the rear panel. Then reopen Mosaic.

See if that resolves it.

Okay I get the same with minimserver. It looks like it’s NOT Asset.

Tried two albums at random with Mosaic and using ver 2 minimserver. In both cases it said error loading metadata.

Sorry Steve but I have limited vision and this was the start of an abandoned sentence that I did not see to clear. "Onr " was intended to be “one” as per the opening paragraph following.

btw tried on two different devices running Mosaic.

Bartok switched off/on. Doesn’t fix.

Just confirming… this DOES work for other users? Yes?

Then it starts to sound like some odd networking problem lying beyond my competence.

Or your copy of the Mosaic control app has somehow become corrupt. Delete it and download a fresh version from App Store or Google Play Store.

Tried the Mosaic on two different computers so I doubt it’s the installation of Mosaic. Also rebooted tablet just to make sure.

I have never seen this particular problem before. The dominant issue is Mosaic not being found on the network or losing contact with the network

Are you using an Android or iOS emulator to run the app on computers ( rather than portable devices)?

One is a genuine Android tablet (vr 8). The other is a virtual platform. In both cases I see the same effect. If it was just one or the other then it might yield something but this is on BOTH platforms :frowning:

I’ll turn on the debug log with Asset and see what it tells me. I’m not sure how to do that with minim, though if you tell me how to capture the log with minim then I’m happy to do the test with minim instead.

OK, so it isn’t the app, it isn’t how the app is delivered, it isn’t the UPnP server software.

That leaves the network and its configuration or the other half of Mosaic in the Bartok. And the server itself of course.

If it has been working fine to date then I would first just switch off your router/switch and reboot to start a fresh session. After all I presume that you or a family member have not been playing with the router configuration?

You also need to check your server configuration and maybe try rebooting it. Are you still getting the music data sent to Bartok with only the graphical information missing?

Lets hope that it isn’t a fault with Bartok. I am guessing that is the least likely cause but it can’t be disregarded yet.

The MinimServer log is found in the Minimwatch menu but that isn’t a debug option. Anyway if the fault also occurs with Asset this doesn’t look like a hopeful route anyway. I had thought of suggesting a rescan of your library but, again, if the issue occurs with two separate UPnP server installations…

I’ve never tried this feature before so I can’t say whether it’s always been this way.

Server in windows 10 (NUC). Rebooted and also the server (asset OR minim restarted).

Yes, the fact that it happens with BOTH servers tends to say it’s not the server. Ditto with the two mosaic platforms behaving the same then it can’t be that. So it’s either a bug with mosaic - can someone send me a screen shot of what I SHOULD see, or I don’t know what?

btw I can’t see what the Bartok has to do with this. I’d think it’s simply a case of the mosaic contacting the upnp server direct for a metadata list for an album.

You should be seeing something like this above.

Mosaic is not just an app that appears on your i-pad or phone. It is a two part application. One part is the control application which you see on your device ( computer in your case). The other part which carries out the instructions from the control app is firmware in the Bartok ( or Network Bridge, Rossini or Vivaldi) itself. when it carries out the instruction it is confirmed in the control app by way of the GUI showing the metadata and playing the music.

is that android?

Yes, Android. However it is only one available view.It is easier for me to take screenshots and to transfer them to my Windows computer. You could otherwise see something like this in portrait mode:

So this might be a Bartok problem then? :frowning:

Not sure where to go from here.