DSDx2 Stutters on High-Res

I am new to Vivaldi. I just got hold of a 3 piece stack (DAC, upsampler and clock). All units are fully upgraded and updated, including the last Mosaic update. So DAC is running v 2.11 and upsampler v 2.10, with network board on v. 503.

I use Roon, with no dsp. My library is AIFF.

Yesterday, while listening with the upsampler output on DSDx2, I experienced some severe stuttering when playing high res files (192/24 and 96/24). It doesn’t happen when playing redbook, neither when using different output settings on upsampler.

How can I troubleshoot?

I have tried a couple of 24/192 files this afternoon and a few 24/96 files with the Upsampled output set to DSDx2 and I have no issues at all.

While you wait for Andrew who is very knowledgeable to respond here are a couple of questions.
1-Do you have the Upsampler and DAC set to Auto WorldClock?
2- You are using Dual AES connections from Upsampler to DAC

I’m not sure if those are important but I’m having no issues.

This is likely an issue with your clock configuration, especially if it’s only happening when upsampling to DSD with an input rate that’s a multiple of 48kHz.


Make sure that the clock cables are routed exactly as shown in this diagram. Be especially careful on the Upsampler as there are 4 BNC connectors in a row and the ones you want are the middle two.

Clock Setup
Be sure that clock bank 1 is set to output 44.1kHz and bank 2 is set to output 48kHz

Sync Mode
On both the Upsampler and DAC check the sync mode settings via:


On the Upsampler the sync mode is the first setting and it should look like this

(that’s a W with no number)

If it’s not set that way (auto wordclock) then cycle through the options until that icon pops up.

The process on the DAC is the same, but the sync mode is the second setting on that list.

Thanks. I will check the cabling. But should it be a clock issue, wouldn’t I be facing difficulties also in other’s output modes (such as DSDx1)?

Theoretically you should be seeing a similar problem with DSDx1, but there are a couple of scenarios that I can think of where that wouldn’t be the case.

For good measure you should also check your dual AES settings. On the upsampler you want to be sure that dual AES output is enabled. On the DAC you want to be sure that dual AES is set to auto.

Will do. I will report back. Thanks

Yes, It was a clock configuration problem. I don’t know exactly why, but group 1 and 2 on the clock were reverting to 44.1. Solved. Thanks for the input

Excellent! Glad to hear that it’s sorted.

In general, if you encounter a stuttering problem it’s in some way related to clocking. These issues become especially apparent with an upsampler set to an operation that requires it to have access to both clock frequencies (like 24/96 to DSD).

I found out the reason the clock was misconfigured. Today, when I began listening, the clock was 44.1 in group 1 e 48 on group 2. When I played a 24/48 file, group 2 jumped to 96, without me touching it. Is this normal?

Are you looking at the input or output numbers on the Upsampler and DAC?

Are you saying that the display on the clock showed group 2 changing automatically from 48kHz to 96kHz?

The clock has no idea what the other components are doing and simply outputs the rate as configured. I can see no way in which the clock output frequency would change absent of an external command. Are you using any 3rd party remote control (either via IR or Serial)?

Yes. I am using a Logitech universal. That is why I put the clock in lock mode. Let’s see how it behaves. For now, everything is perfect

I just figured it out. The clock share codes with my pass labs xp30 pre amp. In locked mode everything is fine

This is what I was suspecting. Unfortunately, RC5 doesn’t provide enough device types to handle things like clocks and upsamplers so the codes had to get “borrowed” from somewhere.

I have a similar issue with a Lutron lighting controller remote. In direct line-of-sight there are no problems, but if I’m not careful the signal reflects off of one of my speakers just right and that reflection interacts with the direct signal. The upsampler sees the combination as the “Output 96000” command.

So far, so good. Off the topic question: is it possible to use the balanced and the unbalanced outputs simultaneously?

Yes, it is. They’ll both be set to the same output voltage and the volume control will operate on both sets of outputs.