DCS Mosaic Can't Find Devices On Network

Currently running IOS 15.7 on my iPad and iPhone. DCS Mosaic can see my Aurender and Roon Server, however, it ca’t see my DCS Vivaldi Stack including upsampled. I have deleted and reloaded Mosaic, reset the network switch and gateway, etc.

Does anyone have any suggestions?

Thank you

Is this a new installation. Has it worked previously? Check switch and see if the network port is flashing on the port that the dcs upsampler is plugged into. I’d look for a bad connection or bad cat5 cable.

Yes this setup worked previously. I switched out the Cat 5 cable with a new one, however, Mosaic still can’t see the Vivaldi on my network.

My NWB does not read in the cover art on Tidal even after factory reset, but it works on Qobus

Have you tried powering down your upsampler (rear switch) and rebooting?

Hi Ray,

I believe we are currently working this through with you on a support ticket…

You’ve said here that…

“DCS Mosaic can see my Aurender and Roon Server, however, it ca’t see my DCS Vivaldi Stack including upsampled.”

In what way does Mosaic see those devices? Mosaic shouldn’t “see” either of those devices to control them so are you able to clarify this?



Hi Fredrick,

The Network Bridge itself doesn’t do anything with cover art so do you mean that TIDAL cover art doesn’t display in Mosaic but Qobuz cover art does? What device are you running Mosaic on?



Okey! Yes that is correct Mosaic does not showing the cover art since 3 weeks ago.

It is a Iphone 13 Pro 128gb


1 Like

Turn off iCloud Private Relay on your iPhone.

That’s the likely cause of the problem; others on the forum have had exactly this same issue.


Thanks Anup!

Will try it out tonight.

The only thing is that web pages can see the IP adress.

But thanks again👍

Ahhhhh you snuck in there with that before I could do… :slight_smile:



Haven’t checked, but is this Private Relay issue mentioned somewhere prominent in a FAQ on the dCS site? I see this almost daily…

Also, other apps seem to be able to deal with it - maybe dCS should investigate.

Hi Paul,

There isn’t really anything that we can do as it’s external to anything that we have control over - Private Relay SHOULD be transparent but it would seem not totally so.

The downside to posting this up as a FAQ is that once it’s up on the internet then it’s up on the internet for ever and becomes part of the contextless and timeless noise that gets returned as a Google search result so for this one I am presuming that as Private Relay matures then those quirks where it isn’t as transparent as it should be will be mopped up, and the issue will properly resolve as it should do … otherwise there’ll just be another note out there forever that says “don’t use Private Relay as it breaks x”.

Best Regards


If anyone is curious:

Apple Developer Support: Prepare Your Network for iCloud Private Relay

If you prefer video:

Apple Developer Support: iCloud Private Relay Video

I am having the same problem. My Vivaldi stack used to connect with no problems. I sent it away for the Apex upgrade and now Mosaic can’t find the device.
I checked the iPhone issue and Private Relay is off, so it’s not that.

I have just had a similar issue. The cause was that the IP address of the returned dCS unit was now incorrect and it was on a subnet other than shared with Mosaic. In my case correcting the IP address (now fixed not dynamic) solved the problem.

Hi Keith,

Given that it is the DAC that gets the APEX upgrade and the DAC has no network connectivity then there can be no link between this and the APEX upgrade.

In any domestic network the network IP addresses are given out by the router so the first thing to check is that your Upsampler has been given a valid IP address for your network.

What does your Vivaldi Upsampler show on the Menu → Info → Status screen for its IP address?




Hi Pete,

From the conversations I had with Pedro at the time your issue appeared to be that your Upsampler is being looped through your Melco and the Upsampler wasn’t getting a DHCP response through the Melco (it was getting a 176.x.y.z “fallback” address as it had a live Ethernet link but wasn’t getting a DHCP response) so bypassing the Melco to allow the Upsampler to get a valid IP address for your network and then plugging it back through the Melco seemed to resolve that.

If the IP address has been “fixed” (as a static address) on the unit itself then I hope that they have also reserved that IP address on your router too.

1 Like