dCS Lina dac stop playing radio station


I’m listening to a particular radio station and it stops playing when the track finishes.
The station is “Intense radio” (Dutch dance station) and I really love to listen to it now and then.
After listening one track it stops and I have to start the radio station again and again and again.
Can you please look into the issue and see if you can reproduce it? Running Lina 2.0 with mapper 1 and filter 1 upsampling is dxd.

Regards Richard

1 Like

It sounds like a cacheing problem

Before I try I need to know exactly what is happening. Are you using airable ( i. e. the radio service in Mosaic) or are you using another method like the internet stream and a PC ?

If Mosaic radio, when you say it stops, looking at your device screen does the blue " Play" button to the right change from showing a “pause” icon (two vertical lines) to an option to play ( black triangle)? Or is there silence but that button continues to give a pause option?

Does the cessation of sound occur precisely at the end of a track or can it happen at any point during the music?

Good morning Pete,

I’m using the mosaic app and the source is airable.

The cessation of sound occur precisely at the end of a track never in the middle or beginning. My internet connection is super stable. (Never had an issue on my Naim NDX2 with this station) Other stations like PR mellow mix/ PR rock play just fine.

On the Lina screen you can see the blue play button just if the unit is playing.
In the mosaic app the same with the possibility to press pauze.
Only thing that is different is the upsampling numbers, they go from 16/48 to 0/48 and you hear a relay click when it stops playing.

Further more I searched the radio and put it in my favorites nothing special I guess.

Regards Richard

1 Like

If the blue button continues to show a Pause option then it means that it is still connected and playing the station. However the data information suggests that it is still connected but there is no data depth rate being received when silent. You may see something similar with UPnP before the track plays.

I have never come across this before. Mosaic indicates that the station is not using a codec so it leaves me puzzled.

I haven’t found any ends of tracks when it has been playing, what I am listening to just segues from one to the next. However the normal controls such as the play /pause button do not work and I found it necessary to have to reboot to switch the station off.

There is something that suggests that the sound stopping at the track end is the station it self at the time and programme strand that you were listening to. Mosaic won’t know exactly when tracks finish only that it is receiving no bits any more. Try at another time ( i.e. not just later in the same programme strand) and see what happens.

1 Like

Hmm so in your situation the station keeps playing songs but you can’t pause the station. (Switching to another station is still an option I assume, instead of rebooting the unit?)

I have tried to listen to the station on different times including this morning but the same outcome, it simply stops playing when the station presents the next song. Well let’s hope that this is the only station that is a bit quirky.

1 Like

yes, I can’t pause the station. In fact is caused all kinds of upsets so I agree that it :

My conclusion is avoid it :thinking:.

Too bad, enjoyed the 80 and 90 dance music.
Still strange that the Naim NDX2 played it without any problem.

Found a workaround, when I go to custom radio and I use the radio channel mp3 stream then the music keeps playing.
Tried both high res URL’s (http and https) but both stopped playing as well,
On mp3 the bit rate is 16/44.1 and high res is 16/48 perhaps that is causing an issue? Anyway, a small performance penalty on mp3 but at least the music keeps playing. :smiley:

16/44.1 and 16/48 should not cause a problem. The issue seems to be that airable have linked the FLAC stream of Intense Radio to Mosaic and not the MP3 one. To date ( unless I have missed something) FLAC radio has not been supported in Mosaic radio. Further information is required so I am tagging @Phil and @James for when they return from the break.

Airable altered some elements earlier this year , maybe FLAC was incorporated but I have no information on this and presume not. I know that HLS streams were added and there has been the new custom option ( as used by you). but not FLAC AFAIK. That seems to be the culprit.

1 Like

Hi Pete,

There shouldn’t be any issues with playing FLAC streams and there are other Internet Radio FLAC streams that do play OK - what I have noticed is that Intense Radio do appear to change the FLAC metadata for the stream whereas the other FLAC station streams don’t so that could be what is messing things up there … I’ll flag it to the devs though and see what they can see.

1 Like

Thanks for the help Pete and Phil.
Hope the dev team can find a solution to the issue.

Enjoy the holidays.

Kind regards, Richard

1 Like

Hi @Phil,

I can confirm that other high res (flac) radio stations stop playing at the end of the song as well.
You were right the first time regarding the meta data, it seems that the Lina can’t handle it? When I usage the same radio channel but without the meta data there is no problem and the songs keep playing.

I think it’s strange that nobody with a Lina has reported this…bug?

I’m listening to SuperStereo 3 without meta data Without meta data

This is with meta data and stops playing.

Hope the dev team will look in to the issue.

Edit: radio channels were added with custom radio.

1 Like

Richard’s right, and it’s not just the Lina; I just tested it on my Bartók and it demonstrates the same problem, playback stops after the current streaming track is done.


Hi Anup,

It’s been flagged to the software guys and now they’re back after the Xmas break then they are aware of it.



@Phil With network board version 1.4.3 (513) this issue seems resolved.
I can listen to radio channels with meta data without the data stream being interrupted.
Thanks for fixing this issue dCS software team. :pray: and thanks Phil for informing the software team.