dCS Bridge Not Connecting

Hi, I have been away on holiday and disconnected the power to my dCS Bridge, DAC, amp and pre amp. I have tried to switch on the Bridge but it is showing a flashing blue light, rather than settling down once on to a constant blue light. I can see the bridge on my network through the modem and network software but Mosaic is unable to find the Bridge even though I have entered the ip address shown on my network app.

Any idea why the Bridge is not turning on completely?


The flashing front panel LED indicates that the unit isn’t connected to a network - I presume that the IP address shown in your router is the one that the router has given to it but that doesn’t mean that it is still connected to your network.

How is your network bridge connected to your network? Would you be able to (as a test) take the Network Bridge over to your router and plug it in directly using the Ethernet cable that we supplied with it and see if you still get the flashing front panel LED?

Best regards

Phil Harris

1 Like

Hi Phil, many thanks for your prompt reply. I have been able to find the issue and fixed the problem. Since I was away from home for 3 weeks, I turned off, and disconnected the power cable from all my equipment. On return I re connected the power and turned on all my devices, except the power to the Ethernet switch connected to the Bridge……I had been traveling for almost 40 hours so was very tired, but a bit of thinking helped resolve the issue. It’s now all working. I appreciate your help, and it’s great to know that the support from dCS is so good.