Dangerous Bug in Bartok

I’ve been demoing a Bartok for past nine days. The sound has been amazing so I bought one from the local dealer with the plan to quickly upgrade to a Rossini. Everything was awesome until this afternoon when my view changed…

Ok enough polite bs… dCS has fkn pissed me off with their crappy design. This afternoon while listening to music the Bartok suddenly shot up the volume on my headphones to what I have to believe is 100%. I tried to mute it but the mute button didn’t work. Tried to lower volume but the volume control from the app didn’t work. Tried to lower volume via the volume knob on the hardware and that didn’t work. None of the buttons on the front were functional. None of the audio features in the app were functional. I had completely lost control of the volume and was forced to switch off the power.

Fast forward nine hours and my right ear is in pain and both ears are ringing and I’m super fkn upset. I can forgive crappy software because the sound quality is excellent however… this particular bug is completely unacceptable. As it stands… my feeling is the headphone amp is unsafe to use.

Hopefully I haven’t suffered permanent hearing damage. dCS needs to figure out how tf this could happen and immediately fix the software and/or hardware.

In 25 months of using the Bartók HDAC I have never experienced this. I am sorry to hear about your problem, which seems harmful. This problem was also never reported here by the community, so it seems like your unit might be defective.

If you dare to take the risk: can you try rebooting your Bartók, by power cycling it through the power switch at its back, to see if the issue is resolved?

BTW, did you listen to your headphones through the XLR or jack out on its front?

Wow this sounds like a horrendous experience, sorry to hear.

Just to make sure I understand you correctly, you tried muting, adjusting front panel volume, and then same but via app, and finally hard power off from the back panel while the headphones were still blaring at 100% volume on your head? Why didn’t you just yank them off your head or unplug first, then troubleshoot the volume? If your got panicked and didn’t think of this immediate effect step, please keep it in mind for the next time, your health is more important than any hardware product.

1 Like

Well I had the app open on my iPad which I was holding so it was faster to just do that. Obviously I took my headphones off as soon as I realized something had gone horribly wrong. The volume control was indicating -20 db which is normal listening level with my hd 800 which was confusing considering how fkn loud it was. I moved it to -80 and no change. I muted it and the app said it was muted. Just awful.

After removing my headphones I went into every single feature of the app and the control panel trying to lower the volume. The app said the volume was -80 db but that was a lie. The app said headphone level was set to -30 db but that too was a lie. I even switched to line out to shut off the headphone out and that didn’t work.

Obviously the Mosaic software is garbage but I was willing to live with it. The fatal design flaw IMO is that the hardware controls failed to override the software controller.

That is an awful experience to have. I think you should email dCS directly, if you haven’t already done so. I have had one weird episode with volume (on a Puccini player). In that case the problem was a misbehaving remote control putting out a continuous “increase the volume” signal and even the buttons on the player had no effect while that was happening. The circumstances and system are rather different from yours, but it was a case of the cause being not at all what I had thought. (The remote was a guess by my dealer.)

Yeah I was forced to switch it off yesterday since none of the controls were responding. I turned it back on and it appears to be working. However I haven’t listened to anything since my right ear feels abused and they’re both ringing.

This is the third time in nine days I was forced to reboot the dac due to loss of control. The first two times I figured were just due to mosaic being poorly designed but wasn’t going to complain because I use five iPads and an iPhone along with Roon. As a former software engineer I understand that integrating with 3rd party Roon wouldn’t always be 100% perfect. However… mosaic/dCS offers no function to release control from Roon back to the internal system. Maybe I should put in a support request with the Roon issue.

The fact that the physical volume control could ever be disabled is absolutely unacceptable.

I was using my hd800 through the single ended connection. I thank God I wasn’t using a balanced connection.

This is all so upsetting because I was absolutely in love with the bartok and now I’m terrified to use it.

That old saying “If it sounds too good to be true; it probably isn’t” appears to hold up for bartok with headphone amp. I’m not an engineer but my instinct is that dCS should redesign this with a high quality analog volume control. Until then this is just a marketing gimmick IMO.

Let not the tail wag the dog. What you describe is a uniquely isolated occurrence; could be a product defect as opposed to a design defect. I’d give them a good faith opportunity to look into the matter before proclaiming a back to the drawing board conclusion.

1 Like

I take exception to this; to me it is hands-down the best app to control the hardware and music playback. If I had commissioned a developer to build me an app for the dCS, it would be 99% aligned with Mosaic. Lets me cut to the chase and then fades into the background while I enjoy the music.

TRS/ jack plugs [Tip, Ring, and Sleeve, refer to the parts of the jack plug that the different conductors are connected to] can cause a temporary short-circuit condition while the plug is being inserted, or not fully engaged.

The traditional 1/4" TRS connector uses the sleeve as a common ground for the left and right channels. This connection carries twice the current carried by the other contacts. High contact resistance at the sleeve connection can cause distortion on both channels.

If the plug is slightly damaged, or corroded, or polluted, or moved, or not fully inserted, distortion or short-circuit can happen, thus freezing the unit.

I do not say this is what happened to you, but it is a possibility.

Over the years I’ve used several hifi hardware control apps. Since I’m a card carrying member of the Naim cult I might be biased but their app is by far the best I’ve ever used. Without Roon I’d view the streaming feature of the Bartok as something lifted straight from 2010.

The reason I called it garbage isn’t the limited feature set or lack of usability. It’s garbage because it lies about the current state of the Bartok. Based on my experience… the app takes your input (shut off logo or screen, volume, headphone or line out, headphone level etc) assumes the hardware has processed the command to change its actual setting and doesn’t wait for a confirmation before indicating the change on the app. Either my dealers Bartok is faulty, this is a 1 in a billion thing, or the software is poorly designed.

I’ve owned two Naim streamers for almost eight years and they and their app aren’t perfect. In that time I was forced to reboot the streamers maybe half a dozen times. If the app wasn’t able to control the volume or switch sources it didn’t pretend to do it.

So I’ll agree that the quality of the queue management feature of Mosaic is subjective and many people would likely find it suitable. The actual hardware management component is the only part I’d use and that portion, in my 10 day experience, is absolutely unacceptable,

Yeah maybe… idk… I was pretty mad when I wrote that. Prior to this I never spent a minute of my life thinking through the downside to digital volume control beyond sound quality. Also considering I’ve owned at least 100 audio components with a volume control and before yesterday never once was in a situation where the physical control did not change the volume; I didn’t really examine the headphone amp design.

This might be a one time thing but I lost a lot of love for the Bartok yesterday.

Obviously thats not how things actually work.

All command & control functions between Mosaic and Bartok are exchanged through a TCP connection between them that are executed and acknowledged at both layer 3 and at the application level.

Which is why when one rotates the physical Volume control on the Bartok, the volume control on Mosaic reflects that change, in near real-time. It won’t work unless that “feedback loop” exist between software and hardware.

In fact, dCS has supported software-control for decades. Prior to TCP it was via RS-232, which is still supported today, where all checksum’ed control-commands are acknowledged within 50ms of the last transmitted byte, including an indication of how long the unit will take to execute the command.

Just your bad luck to encounter the bug that you did. Rather than random speculations, I suggest you talk to your dealer and have the unit properly examined by people who actually know what they’re doing :slight_smile:

3 Likes

That is the right way to go about it as there isn’t really much we can do about it via this forum except acknowledge that this is a most unusual issue that we have not come across previously. However I am confused as to this particular Bartok. I read the OP’s initial post as the Bartok that is faulty is the one he has been demoing “for the past nine days”. He has also bought one but that is yet to be delivered which he confirmed in a post in another thread two days ago when he says that his Bartok will be available next week .

So , first stop has to be the dealer as it seems to me that it is the dealer’s unit. That also opens a question as to its past usage and whether that is linked to the issue.

3 Likes

Sage advice @PAR!

In my multiple hour daily use of the Bartok since 2019 I have likewise never encountered a similar issue. Worst that has happened was the unit got stuck in its initial splash screen once after an unexpected power outage. Other than that, I have had no operational issues whatsoever.

@Katzky given your loss of love for the Bartok , maybe skip the Bartok altogether and go for the Rossini as this seems to be your stated eventual destination :slight_smile:

1 Like

First off, let me start by saying I am very sorry to hear you have experienced this fault.

This is the first instance I have ever come across of a unit exhibiting this behaviour. There is not any mechanism within the product that should allow the volume to jump up in this way without any explicit user input, so this is very unexpected.

The best thing here will be to get your dealer involved so we can get to the bottom of the issue. To that end, I will send you a private message now to get the ball rolling.

1 Like

Just to be clear, the indicated volume didn’t jump up from -17. It was just clear it was much louder than it was in previous track. I did have volume leveling engaged in Roon

I do too, and it is not always effective.