Cannot detect dff/dsf file on network drive


Im having this very very strange problem detecting dff files via network. I am able to read all music files (wav and flac) files through Mosaic but it cannot detect any of the dff/dsf files.

The dff file is there, and I can confirm the file is readable. I copied one file into an usb drive and plug it at the back of rossini and Mosaic detects the file!

I thought it was my NAS so I copy the same file into a windows folder and share through UPNP and Same situation. Detect wav/flac but not dff !!!

I suppose its not the Mosaic error because I tried using portably player (dff) and it also cannot detect the dff through network drive. Anyone experience this issue with dff/dsf and how to resolve it.?

Furthermore, I can detect the dsf/dff tags properly through dBpoweramp , and read through foobar, but it just cannot show the file thought the any media player (portable or mosaic) like the file is missing.

Any suggestion would be appreciated. Thanks

Hi sili,

The file type recognition is actually a function of the UPnP Server, Mosaic will only show what it’s told as available by UPnP Server. So, that’s likely where your problem is.

What UPnP Server are you using?

Hi Anup,

Thanks for the response. I figure out the caused after doing a bit of research online and resolved it. I’m going to share it here in case someone else happen hit the same problem reading dsd files in the same scenario:

The problem is that many DLNA servers /does not recognize DSD at all , so it cant recognize dff/dsf format as media format. My Asus routers that has a built in DLNA server does not support it. Windows 11 media sharing does not support it, nor miniDLNA server(I tried all!). To test, just rename the dsf/dff file to a .flac or .wav extension and mosaic will display and play properly.

The solution is to use minimserver instead. Either get a NAS that supports it or install the minimserver or/ plugin. When I install the minimserver it’s all resolved and can read also dsf/ddf formats.

Good to hear that you’ve solved it. The FAQ section does cover this, and plenty more :smiley: