Bartok's streamer freezing with large id tags


I didn’t try recently, but the Bartok just froze every time after I played a tune from Roon with very large id tags. The issue just occurred from the NETWORK input, never from the USB input.
French retailer just told me to edit and reduce the string size of the id tags of the tunes causing problems to the Bartok…
But handling large text size is just basic computer stuff that the Bartok shouldn’t choke on.

Here below a picture of a tune that was causing such an issue.

Thanks for your support,



Erwan, this seems to be input from Qobuz playing via Roon .The "tag " is displaying both the track title and, in blue, the track information in the same field ( in the standard Qobuz format which is the clue along with the display of the “favourites” heart icon). Normally with Qobuz “track information” is displayed only when specifically selected and in its own field, at least both via Mosaic and via Qobuz’ own players. The screenshot is presumably of Roon or another source and not Mosaic as the landscape layout is unfamiliar to me.

I am playing this piece from Qobuz using Mosaic as I write and it plays fine. So as far as I can judge this therefore seems to be a Roon issue.

There’s no issue either on my side if streamed from Qobuz.
The problem only occurs with the files purchased from Qobuz which have extended id tags.
I can share those files if needed (private message), but can’t let everyone access them from a public link for obvious legit reasons…

Thanks for replying Erwan ( and for the other answers which I will come to in due course).

I too download from Qobuz. I have also dealt on other forums with people having trouble with Qobuz metadata. The reason is that Qobuz offers two ways of downloading. If you pick the wrong one for your purposes it seems that difficulties may arise.

When you look at the download page you should see two options. One is to download to your Qobuz player app. The other is to download to hard disk. It seems that you may have been doing the former where the metadata is in a format to be displayed in Qobuz’ own players. The latter option provides the metadata in a universally applicable way.

Here is an example of one of my downloads from Qobuz. You can see that the file itself has the main fields in a normal way and that the track title , artist and other information are in separate fields:

The file for each track can also be displayed in ID3 format;

Again there is no concatenation of data from different fields.

May I suggest that you go back to your purchase page in the Qobuz download store and download the album again from the right hand downloading option ( this has a green option title " Download my Music" , the other version for Qobuz Mac or Windows version shows in blue) and try again. You will need to install a small piece of freeware to unzip the downloaded folder called 7-Zip.


I always download to hard disk and never use the Qobuz app.
I always get my files from .tar archives.
So the problem isn’t there.

Thanks , well it looks like your 3 questions have me beaten. Not having Roon I have no idea why the separate track title and track information fields in the download from Qobuz are being concatenated. I have never had any problem using Qobuz downloads playing them either with Mosaic via ethernet from my Melco NAS or, in my old Win 10 system via USB, with JRiver.

Maybe there will be some further contributions from others during the week.

Just PMd you, Erwan. Happy to help out with some tests on a similar setup if you’d like.

Thanks to @PAR for pointing out that the tagging differs depending on how you download from Qobuz. I had no idea. That sounds like a terrible “feature” — would be interested to hear the thinking behind why they do that. One of my downloads from Qobuz recently had NO metadata, though, so I’m not sure it’s all as consistent as we think. (With a big library that’s not too surprising!)

1 Like

Its not the metadata per se that is different but, apparently, its formatting, one version I assume in order to suit the layout of the Qobuz player. Quite a few guys over on AudioAsylum were complaining that they had to manually reformat the metadata.

I have never had to reformat anything that I have downloaded from Qobuz using the to hard disk option. I could change the genre from “classique” to " Classical" but even my poor French can cope with that.

Interesting about missing metadata. I have never come across this but I understand that the metadata itself is not generated by an army of discographers at Qobuz but is as supplied by the record label albeit then sorted into the standard Qobuz form (automatically using ID3 fields?). So maybe in your example the record label simply didn’t provide anything?

@Erwan — those files are working fine here:


They also work fine using Qobuz via Mosaic though this is a stream not a download. Have you simply tried playing the album from your NAS using dCS Mosaic instead of Roon? It is one way of eliminating at least one element from suspicion. If the problem still exists then it isn’t a Roon problem. If there is no problem then it is likely to be a problem with Roon. However, given all of your points there seems to be something very wrong with what you are experiencing.

@PAR — the files that I was playing above were the ones from Erwan himself. His downloads, played from my Nucleus+ internal storage with Roon. I don’t think it’s a Roon problem, unless there’s something peculiar about Erwan’s setup that we haven’t worked out yet.

Hi guys,

As per discussion with dCS support in an email thread corresponding to the 3 issues I recently opened, they acknowledged the current issue was a known bug they fixed in the last update.

Therefore, I’m closing this issue.