Bartok update problems

hi,Dcs
I got a Dcs bartok from local dealer two days ago.It can be used normally, but when I want to use the Dcs Monsaic Control, there some problems appears. When I downloaded the Monsaic app and opened it, the app showed my Bartok network firmware need to update firstly. When I clicked the update bottom, I saw the Bartok showing NO INPUT in short time and recovered to connect to network, and nothing happened. The updating failed. I tried serveral times, it didn’t work. I used pc to open the bartok web page. I found my Bartok “Device version: 0.64.501.0xa23a821 Airplay version: 190.9.” And I couldn’t update from the web page too. It showed “network error httprequest to the selected device failed.” My bartok network board version 501,app vision 1.4.10.
Can someone help me solve the problem? Thank you.

You really need one of the dCS personnel to login here to answer your question in full. So be a little patient ( I can understand how frustrating this must be for you with a new product).

In the meantime the standard advice when updating is to powercycle the Bartok first by turning it off from the rear panel. So don’t go straight the update button in the Mosaic app but switch the Barok off and on first then try the update.

If Andrew or James from dCS reads this: I tried to check the latest software information but, once again, the documentation page on the dCS website is not functioning correctly. There is no link appearing today in any list of values for either Bartok or Rossini Transport.

Try switching the unit off from the rear panel, waiting 10 seconds, and then switching it back on. When it’s fully online use the update check button in the webUI rather than in the app. If this still results in an error then there is likely an issue with your unit being able to contact our server. We’ll need to get your dealer involved in order to do a manual update.

I tried the update check button in the webUI, but failed…

You mention this in your first posting. Is this a repetition of that or a second attempt? Did you try the power cycling advised by myself and Andrew?

Andrew has also offered to involve your dealer to manually update your Bartok. That may be your next step but I would imagine that you will need to advise him where you are and who the dealer is.

Thank for your concern. I used the method which you and Andrew mentioned above. The Bartok showed NO INPUT in a short time and then nothing happened. The regional general agent is Radar Audio Company. I contacted the seller, he promised me to feedback my problem to Radar Audio. And the seller said the problem is relatively common. The monsaic is seldom used. In my view, I can use Bubbleupnp instead of the monsaic, but I feel uncomfortable if the equipment can’t update.

Coco, make sure your broadband isn’t firewalled; the Bartok and your Mosaic Control device (or your PC/Mac if you used the Batok’s WebUI) has to have proper unfiltered connectivity to dCS’ Firmware update servers on the Internet.

Bubbleupnp is not really a substitute for Mosaic. They have different functions.

Bubbleupnp is basically a UPnP server ( hence its name). Mosaic is a control application and requires a separate UPnP server installed on your NAS . Mosaic only officially supports MinimServer for the latter and use of anything else can produce odd results ( lack of gapless replay, odd track order etc). See page 13 of the Bartok user Manual.

https://minimserver.com/

You appear to be the second owner of this Bartok by your use of the term “seller” ( though I may be wrong) and I am unsure what your position is in dealing directly with Radar if it is necessary for them to be involved to solve your problem. I hope that either James or Andrew of dCS will be able to advise you further on this. I assume that you are situated in the HK region.

In the meantime Anupc makes a very good point in checking that any firewalls running provide access for Bartok/Mosaic .

It may also help if you could confirm how the Bartok is connected to your network just so that can be eliminated as a source of your problem and why you see " No Input" on the Bartok’s display. Sorry for asking the obvious but the Bartok is connected via the ethernet port and “Network” is the digital input selected? That " No input" message may indicate a very simple issue - that there may be a problem with the ethernet cable connecting the Bartok to NAS or for NAS to router etc. ( depending on your system configuration). Have you tried alternatives?

NB: Despite what your vendor said, AFAIK Mosaic is used by virtually all owners of the network players in the current dCS range.

We have seen issues where some ISPs in some countries block access to our update servers (among a huge number of other sites). I suspect that this is the case here and the distributor will be able to help out. This issue is common enough that we implemented a number of changes in Mosaic 1.0.2 that make offline updates easier.

1 Like