Bartok Running at wrong speed on usb

Hi,
Using my Mac Mini via USB the sound crackles /distorts as if it’s running at wrong speed. If I reboot the Bartok the issue resolves.

Also, the sound cut out in the middle of a movie and I had to reboot to restore it. Other DACs work fine on n the same set up

David, in order to make any sensible suggestions as to why this is happening we do need to know what your set up is. Not just the components but how they are connected and that includes details of your network (where it is likely that the solution to the problem resides).

Hi Pete, thanks for the reply. Happy to provide details of my network etc. But how can a Network setting affect a USB connection to the DAC?

Steaming via Ethernet works perfectly, as does streaming via UpNP. Network is: Cisco 2960 switch - EtherRegen-Bartok.

USB conection is: Cisco - EtherRegen -Mac Mini M1 versio -Innuos Phoenix -Bartok
David
David

Cables BTW are Blue Jeans Cat 6 unscreened

Thanks Juancho for the additional information.

If your source is streaming which requires network connection e.g. to internet this can happen. It did to me when I was using a PC/USB based system . However the cause in my case would not be applicable to mac as it was a problem arising from ASIO or WASAPI sessions and related only to 24/192 streamed files. There are also issues which may arise if you are using mac as a server to send locally stored files to Bartok. If you are doing this with network connection then please ensure that you use compatible UPnP server software ( e.g. MinimServer) as use of others may result in unpredictable behaviour.

Anyway there is something which , in your set up, is unique to USB replay - the Innuos Phoenix. What does the Phoenix do? It is a USB conditioning device which re-times the incoming data before sending it to your DAC !. So you therefore have a timing problem with USB connection that does not occur with ethernet connection .

Although I cannot guarantee that this is the root of your issue it is logically the first thing to investigate. Perhaps there is a setting with the Phoenix that needs attention or it is faulty? Whatever I now think that the answer may not lie here in the first place but with Innuos to whom I would suggest that you now direct your question.

The movie sound issue may not be related if you were taking the audio feed from a TV’s digital output. There are known issues with some TV brands due to the way that they have implemented those outputs compared with dCS’ very tight input specifications which are necessary in order to ensure the highest quality of sound.

Hi Pete,

The Innuos simply re-times the data packet, not the audio signal. It is totally transparent to anything connected thru it inc. printers. It works perfectly with other DACs and the Mac recognises the Bartok thru it, so there would be no point referring it to Innuos. There are no settings on the Phoenix. It’s on or off. I can try taking it out the chain, but it was working perfectly for one week before this started happening.

When I refer to movies, I’m referring to eg Netflix. We only stream thru the Mac, never the TV.

When the problem occurs it applies to anything sourced thru the Mac. Eg Qobuz. So it’s something peculiar to the Bartok, which can be corrected with a reboot.

David

That being so I am stumped. However the fact that the movie fault also occurred with a streamed source may also support the idea that it is a network problem.

I have looked through the archives and this issue has been reported before. Here is a thread. You will see that internet/network issues are suggested as the cause several times. There is also an explanation of why a reboot of Bartok provides a temporarily fix if it is a network problem . However there is ultimately no clear conclusion/solution.

As this issue seems to have a repetitive and inconclusive history it may require dCS themselves to provide an explanation. Perhaps @James or @Bashcroft could chip in?

Meh - I switched to Roon, installed their server on my synology box and everything has been working perfectly ever since.

1 Like

Thanks for the further input. IME this type of noise is caused by the DAC not synching with the data stream from the source (Mac in this case). Whilst the original signal-Netflix, Qobuz-is being streamed the Mac is doing the rendering and the DAC is simply playing / converting the digital signal. That it’s not a network issue is supported by the fact that the Bartok will play Qobuz via Ethernet perfectly when this is happening and the Mac will play the audio via its internal speaker or indeed the TV audio via HDMI. Of course all is working fine today :grinning:

I’m afraid I didn’t get on with Roon so that’s not an option for me.
David

David, more than likely this is due to whatever playback software you’re using (you don’t mention what it is) and the USB drivers on MacOS. dCS is not the only platform encountering these sorts of USB playback “speed” issues.

Even though you don’t use Roon, have a read through the following thread on Roon.Community - it describes exactly the wrong-speed problem on other platforms, and playback software other than Roon as well. Start from Brian Luczkiewicz (Roon CTO)’s post at very the bottom, where he describes in layman terms exactly whats going on;

Thanks Anup. But if you read my thread it’s clearly not software related. It happens on Qobuz and Netflix streaming so anything connected by a USB. So unfortunately nothing to do with software and all to do with that USB interface

Just to expand on my brief post from last night, the issue occurs with whatever software-Qobuz or Netflix players-are being used on the Mac Mini. I do agree with the Roon explanation that it’s a handshake issue between the Mac Mini and Bartok. However, as it’s a handshake issue that only occurs with the Bartok, and no other USB DAC, it follows it’s a Bartok issue. I have a sneaking suspicion it only occurs when I select USB via the Mosaic App, and not if I select USB via the front panel button but I will experiment a bit more with this.
David

You may wish to check the setting as described on page 38 of the manual (v02). I recall having a similar problem when using a CD player’s USB as input. Changing the “sync mode” to M on the Bartok for the usb input resolved the problem.

Thanks. I did check that and it’s correctly set at Master. Still haven’t managed to get the DAC to do it when selecting Source manually…
David