Bartok IP stuck on old network

Hi. I changed my network recently, which included a change of router brand handling the DHCP. The old DHCP IP was whereas the new router’s DHCP range is

My The problem is that my Bartok is stuck on the old DHCP range ( and I’m not able to access it via Mosaic or otherwise on my new network (

I have tried power recycling to get it to recognise the new DHCP IP address but this did not help, it still shows the old DHCP IP address.

How can I get the Bartok to recognise the new DHCP IP address, as I’m not able to access the current IP via a web browser?

Those are some pretty specifc DCHP ranges, I’m assuming your network is a little more complex than a standard ISP router plugged into the wall? :smile:

In which case, I would wager the Bartók has been set to a static IP address as opposed to using the router’s DHCP, hence it sticking on the old address (as it should automatically receive the correct address from the new router).

Easiest way around this without losing Mosaic playlists, or resetting your streaming service logins in Mosaic, is to change a device to the same IP range as the Bartók, then go to the web interface and set the Bartók back to DHCP from there. What device(s) are you trying to connect to the IP address on? I can advise on how to do this from there.


Thanks for this reply James. Before venturing down a technical path to solve this, I unplugged the Bartok overnight, then plugged it back in this morning and switched it on. It booted with a new/updated DHCP IP on my new network (.77 range). Problem solved. I appreciate the helpful feedback you shared, it would have been my next step had the overnight power off not worked.

1 Like