Bartok and Rossini dac problem using optical connection

A bit late to the game, but the Mutec MC 3 has an optical input and a reclocking function that replaces the existing timing signal.

Phill

Subject to one’s overall system design and capabilities I have found a simple solution to preserving full home theatre multi channel and TV out sound (with just one set of driven L and R main speakers fed by the dCS Bartók in a single music and home theatre room) AND whilst using a recent 86” LG TV, namely:

Even relatively cheap home theatre surround sound processors have RCA analogue pre-outs. (I have a higher end Yahama processor, works well for its purpose).

I connected RCA leads from these analogue pre-outs to a cheap but effective (and physically tiny) powered Bluestream A-D converter (this unit has the D bandwidth to pass through Dolby etc), D output from this unit then plugged into Bartók’s TOSLINK (though the Bluestream has a coax output as well if preferred). Turned dCS ‘Buffer’ option off in the Mosaic app, this is crucial for audio-video syncing as the Bartók manual makes clear.

TV feed is HDMI ARC back to the Yamaha processor.

Works beautifully, no audio delays, no clicks, full home theatre sound and L and R audio via Bartók when in home theatre multi channel surround mode. Slight negative is having to manually switch Bartók inputs for home theatre sound from Apple TV, Pay TV, etc (though a Control 4 or Savant system could potentially do this via the Bartók IR input on the unit’s face).

If a room has separate speakers just for a home theatre application (vs pure music use speakers) from a home theatre processor none of this is an issue, but very few people do that let alone its potential aesthetic oddity.

Maybe one day dCS will see the need to cohabit with home theatre applications and install a set of RCA analogue in sockets for L and R channels with fixed audio pass through volume a la the Linn DSM. There’s a lot of users that want both a high end music system and to run a home theatre system as well in the same place.

2 Likes

Intriguing; thanks for posting. I may give this a try just for the fun of it. I do in fact have a full home theater rig in the same room as my audio speaker system with the speakers built into the walls, and I have successfully passed audio over to the Vivaldi. I had some sync/buffer issues, but I got those solved. But it will be fun to see if this is a better solution.

Certainly worth trying Greg. If you do pursue it, here’s the link for the small but effective converter I use:

https://www.blustream.co.uk/digital-audio-converter

Thanks Richard! Looks very similar to something I sourced off Amazon. Probably fool around with it over the holidays.

I’m not sure if owners are still experiencing these dropouts when connecting from their TV to a DCS DAC via Toslink. I have a Sony OLED and it’s worked fine with a Bartok for 6 months and then fine for another 6 months when I upgraded to Rossini.

Then, approx 2 months ago, I started getting the dropouts as described - clicks coming from the DAC as it was resynchronising to the TV output.

I checked all the usual settings on both TV and DAC, replaced the optical cable, all to no avail. I then purchased an ifi SPDIF Purifier2 as that reclocks the signal. Initially going from Toslink input to to Toslink output on the ifi made no difference, still dropping out. I then tried the SPDIF RCA output from the ifi to the corresponding input on the Rossini and, hey presto (and fingers crossed), the issue seems to be resolved. It’s been in for 2 weeks and no more dropouts. So it’s converted from Toslink from the TV to RCA into the DAC.

It costs approx £180 in the UK, is quite neat and unobtrusive (I plug the ifi straight into the back of the DAC without a cable) and comes with its own power supply.

So far I’m very pleased with it although, of course, I wish it hadn’t been necessary and I’m a bit confused as to why the problem appeared out of nowhere when it was previously working perfectly…

I have recently changed our SKY box to take advantage of the newer Q model. Unfortunately I now have locking issues via Toslink. This was never the case with prior variants of SKY’s boxes. For info this is into a Vivaldi upsampler. What I note is that the frequent dropouts occur only when the SKY box is playing live. When I replay from a recording no problems. Also, as with other’s findings, I have no dropouts with an alternative DAC (I accept that dCS pursues a tighter tolerance envelope than maybe some other digital suppliers) non-the-less, it’s an issue and it’s perhaps the most popular setup. Other than that I find the Q box has usefully upped the volume on the Toslink output (??? I thought it was a fixed Voltage, very well defined). Now I don’t have to change my DAC output voltage to 6V in order to get satisfactory volume levels.

Make sure you have the clock set to sync to the audio stream from the SKY box (“A” mode.)

I second that.

I know this is a pretty old thread but I’ve been facing this issue with my LG TV and Vivaldi and have been trying various solutions. Here are my results, which may hopefully be useful to anyone else facing this issue.
Of all the things I’ve tried, all but one failed to resolve the issue. None of the following worked:

  1. Optical directly to the Vivaldi Updsampler
  2. HDMI ARC to a box that extracted the audio and output to coax, which was connected to the upsampler (therefore the issue is not just with optical)
  3. Both optical and the above coax fed to an ifi iPurifier 2, which claims to reclock the signal. No luck.

Finally as an experiment I borrowed a Mutec mc-3+ USB and slaved it to the same Cybershaft master clock that feeds my Vivaldi clock. This completely solved the issue! Of course the Mutec costs over $1000, but Netflix sure sounds great now :slight_smile:

I found it interesting though that the ifi didn’t help, since it’s also supposed to reduce jitter.

Hi Jeff,

Did you try setting the audio sync to “M” (Master) on the Upsampler?

I’m running TOSLink from an LG TV myself - initially into a Rossini player but latterly into a VOS - with buffers off (for lip sync) and although “A” (Audio Sync) SEEMS like the most suitable setting to use it still gave regular dropouts (two dropouts about a second apart repeating roughly every 90-120 seconds) whereas switching to “M” (Master Sync) solved all the dropout issues for me.

Phil

1 Like

Hi Phil, I don’t recall trying master, but I did try Auto Word clock, since I’m using a Vivaldi clock. Will Master work if I have no clock cable between the upsampler and the DAC?

Hi Jeff,

The honest answer is “I don’t know til we do some testing” but my issue seemed very similar although I used slightly different kit to you.

I have been using a Rossini Payer and a Vivaldi One as my dCS kit and using the TOSLink outputs from my HTPC and Sky Q boxes I didn’t have any issues at all (I was using a TOSLink digital delay unit to dial in audio delay to bring the sync into line) … but taking the optical out straight from the TV or using an HDMI ARC Audio extractor to pull out a TOSLink feed (so I could use the TV as the input selector and forget about dialling in a delay) both left me with a repeating pattern of two dropouts very close together (maybe a few seconds apart) that repeated every 90-120 seconds or so.

Obviously you’re using the Upsampler and separate DAC so it would be good to try to chase it down within your setup … and see if there is a difference between going TOSLink into the Upsampler or into the DAC.

Phil

Let me try some other configuations over the weekend. Should be interesting :slight_smile:

I continue to experience this problem with Sky q - only with the close tolerance dCS dac not with my other much lower cost dac. What I found was the problem is only playing live - not from a recording, to overcome the issue day to day I simply press pause for 10 seconds or so, then play. In my case the dropout issue stops. This problem though was never the case with any of the pre ‘q’ Sky boxes I had, so nice to know they moved forward on quality- not.

May not be related, but I have to turn off the buffer on my Rossini when connected to the TV.

If you do not need a USB input, the ‘normal’ Mutec MC-3+ will also do the job and save you about $450.
Though it costs still somewhat over $1000.

1 Like

Hi Paul,

Yes, otherwise you’ll get quite a delay due to the buffer buffering … generally the output from a TV doesn’t change from 48kHz sample rate though so the advantage of the buffer in this case (muting on sample rate changes) isn’t an issue.

BR

Phil

Hi Martin,

Try setting the sync type on the input to be “M” (Master) … I used to get two dropouts roughly 5 seconds apart every couple of minutes using TOSLink from my LG TV which is only fed by Sky Q and that resolved that issue for me.

(…and of course turn off the buffer or you’ll have awful lip sync issues.)

Let me know how you get on.

BR

Phil

Phil I’m taking Toslink to the Vivaldi upsampler set to ‘audio’ . I have a Rossini clock taking both the upsampler clock inputs and the 3rd clock out from Rossini going to a Scarlatti dac. I don’t think I can implement master mode without changing cables around.