App not finding Rossini

Hi, my Rossini has been working perfectly until now. The mosaic app is now not finding the device. Internet is working properly. Have rebooted unit and internet. Unit is hardwired to router. Tried to access unit with ip address on browser but getting message that server is not responding. Any thoughts? Thanks

This does not sound like a problem with Rossini. If Rossini cannot find Mosaic app and you also cannot access your router using its network address then that is where the solution to the problem is likely to be. I would first of all try the simplest fix. Turn off your router, not just internet ( e.g remove the power connection), wait a few minutes then reboot it checking that the indicators for connection ( Power,LAN, WLAN and DSL) are illuminated. Then try Rossini and Mosaic again. Does your ISP offer support otherwise?

Hi Pete,
Thanks for your response. I rebooted the router, all connections illuminated. I entered the Rossini’s ip address into my web browser but no response. The mosaic app and dcs rossini app still do not find the device.I have tried the app on an iPhone and iPad, no devices located.

There are contributors here who know a lot more about networks than I do e.g. @Anupc or @struts001 . However this sounds to me to lie outside of the dCS domain per se and to be an issue with your LAN or router. Are you able to get access to the internet otherwise via your PC or Mac?

Yes, I have full Internet access.

If you have full internet access it means that your computer is connecting to the router. Is your device running Mosaic app also on the same network?

Mosaic discovery errors are mostly caused by a configuration issue. However as it looks like we may need to go further others with better knowledge than mine will need to have some idea of your network setup including router model.

All devices are on the same network. The Rossini display is showing the network input, which I assume means that it is connected to the network. When I remove the cable it shows no input. Would a factory reset be advisable?

No. All the reset does is revert the options such as display brightness and filters etc. to how were set when the unit left the factory.

I am hoping that one or both of the members tagged earlier by me will respond and advise you on configuration issues. As we have various time zones involved you may need to wait a few hours. In the meantime advise what your network is including router model.

Thanks so much for your help. I’m in Long Island, New York, USA.
It’s 6:27 PM. , much earlier than your time.

I think @PAR has already suggested all the obvious steps here. This sounds very much like that common effect known as “random weirdness”. I have had a couple of instances of this already in the few weeks I have had my Bartók. Things like Roon is working fine but Spotify Connect doesn’t show the Bartók as a device, or Mosaic connects but the Bartók app won’t etc. In all cases a Bartók restart has fixed things.

Since I take it you haven’t changed anything and networks don’t generally reconfigure themselves my only suggestion, which it sounds like you have already tried, is to restart the Rossini (off, magical 5 second wait, on) and also restart your client (phone/tablet).

If that doesn’t work then the only other thing that springs to mind is a possible IP address conflict. This can cause all manner of weirdness and have you scratching your head for hours so is always something I check early on when troubleshooting network problems.

If the above doesn’t work then per @PAR ’s suggestion you’ll need to tell us a little bit more about your network. Do you use an all-in-one wireless router? If there is a problem with your WiFi your iPhone could still be connected to the internet (via cellular) but not to your LAN, so it would not see the Rossini. Just to eliminate WiFi as the culprit are you able to connect a PC directly to your switch with a cable and see if you can ping the Rossini from there?


This is a gentleman who I have just spoken with on the phone so we are currently in touch and working this through.

For everyone else, the first thing to check here would normally be what IP address is the unit showing?

Is it sensible for the customers network (is it a non-routable IP address) or is it a 169.254.x.y address?

If the latter then it is likely that the unit has a “live” network connection (to a switch perhaps) but it isn’t getting a response from the customers router.

It’s very easy to go disappearing off down unnecessary rabbit holes whilst skipping the basics…

In this case the unit is picking up a 192.168.7.x IP address from the network port in his listening room and a 192.168.1.x IP address when plugged directly into into the router in his garage.

This would suggest that there are two nested routers in the system … his phone / tablet is getting a 192.168.7.x IP address but for some reason when his Rossini is on the 192.168.7.x network neither his iPad is able to find the Rossini in Mosaic and his Mac isn’t able to get to the Rossini’s web interface either. The system was installed by a third party and so we are going to contact them to see if we can get some information regarding the setup of that network.




…or could this be a case of one of those pesky VLANs that cause you so much heartburn?

Anyway, good to know you’re on the case Phil, sorry for interfering. Will be interesting to hear where this ends up.

1 Like

It could be an issue caused by a port-specified VLAN … however the LIKELYHOOD is that it isn’t a router that has had VLANs set up on it as it’s an ISP supplied main router and it’s highly unlikely that an ISP supplied router supports that (and multiple DHCP ranges).

(Plus, it USED to work and it’s unlikely that ports on switches have been messed around with.)

It’s more likely that someone has set up a cable router (on a 192.168.7.x range) inside of the ISPs router (on the normal 192.168.1.x range) to separate the customers network from the vagaries of an ISPs router but still retain the ISPs support (pretty common and I do it myself) - the downside is that the network is then running double-NAT but MOSTLY that isn’t an issue.

Anyway, hopefully I can get in touch with the people that set it up and between us resolve what’s going on …


1 Like

I was teasing Phil, sorry, I should have put some kind of emoji or something. Anyway, you’re the expert here and I’ll stay out of your hair.

Thank you Phil and the other experts on the forum.I was able to contact the network installer and he will be coming to the house on Wednesday afternoon. He prefers to troubleshoot on-site. I will loop you back in when he comes. Thanks again.

Hi all,
Phil was correct. There was a second router set up as part of a EERO system throughout the house which was not working properly. Once replaced, all is well and Mosaic is finding the Rossini and functioning flawlessly. I appreciate all the feedback from the forum experts. It certainly was a learning experience for me. Phone response from DCS (Phil) was impressive. Thanks again.

1 Like

Awesome! Glad you’re up and running - sounds like your network man was on the ball!