Odd behaviour playing from track queue in Mosaic

When I run Mosaic after an interval of a few hours I sometimes find that when I use ‘play from here’ with the first track in a music track queue I’ve created this first track plays but playback does not continue to the next track in the list. If I repeat this process then the tracks play continuously starting from the first track. Very odd. Has anyone else experienced this behaviour? I’m running mosaic on an Android tablet.

Hi, my ‘odd behaviour-thing’ with Mosaic (iPhone) is the appearance in My Albums and My Tracks of albums and songs which I did not ‘put’ there myself. Very annoying.

Problems like odd track order, missing albums etc. and (perhaps) the appearance of albums/tracks in unexpected places is usually caused by using a UPnP server other than as specified by dCS. Are you using something other than MinimServer ?

NB: I don’t think that the OP’s problem is necessarily of a similar nature as he seems to be selecting “Play from Here” but is getting the equivalent of “Play Now”.

Just to clarify, I am using MinimServer and “Play from Here” in the Queue tab in Mosaic.

Thanks for the additional information David.

I am trying to replicate your problem so far unsuccessfully. I am now wondering if there is something I am am missing about what happens in the interval:

Have you just wandered off , say, mid album stopping or pausing play then trying to restart from that point for the next track when returning? Or are you switching off your device running Mosaic during the interval or using it run some other application?

I use an Android tablet that is dedicated to running Mosaic. When I have finished a listening session I clear the play queue i.e. delete all entries, then under the service tab go up to the server level. I then use the ‘Close all’ for Android apps and turn off the tablet. The ‘interval’ is typically 6-8 hours: morning/evening or over-night.

Hope this detail helps.

Thanks. I have tried various “restart” permutations including closing Mosaic altogether but I have left the interrupted album in the play queue and have not cleared the queue. In all cases so far the track selected as " Play from Here" has been automatically followed by the next one in sequence when restarted.

So, it is first clear the play queue. Leave awhile. Reopen Mosaic, select a new album ( I am also assuming that we are talking local files via UPnP), queue it, select “Play from Here” in playlist. However only the starting track that was selected plays.

I hope that I have got this correctly and will now go away and try it :slightly_smiling_face:.

“( I am also assuming that we are talking local files via UPnP)”

Yes, the music files are in library on a NAS connected to the same LAN as the Network bridge. The behaviour I described does not happen every time I re-run Mosaic: I’ve not been able to see any pattern in the intermittency of this behaviour.

Intermittent problems :frowning_face:. Always a PITA.

I have been trying but I cannot get Mosaic ( iOS version) to replicate your issue. I have the Android version too and if you think that is relevant I will try again with that.

I guess that you will have tried the obvious like deleting Mosaic and reinstalling a fresh version from the App Store or Google Play Store? Mind you with an intermittent problem it may be difficult to see if any initial improvement is going to be stable over a period.

OK I deleted the Mosaic app from my Android tablet and re-installed it from the Google Play Store. Over the past 3 days I’ve had 7 listening sessions accessing my music library on the NAS. No problems at all until today when it re-appeared i.e. after choosing ‘play from here’ in the play queue the first track was played and then play stopped.

I cannot add much at this point as I cannot get my own setup to replicate your intermittent fault. I can only hope that one of the dCS staffers will be able to chip in from here.

OK, thanks for the attention.