New host firmware upgrade 1.01 (Bartok)

Hi Support!

I checked for updates using Mosaic app and Bartok find new host (?) version 1.01
I tapped to install…

How long should this update be installed? Did I have to reboot Bartok after or had to do this before? I’ve been waiting for more than 20 minutes and nothing happens.

What does this update contain?
Is it possible to add any indication of update progress or a warning about a reboot? In this case, it is unclear whether I should wait indefinitely or whether to hard reboot the device, because it hung…
I don’t see anything on the DAC screen also…

Thanks in advance

1 Like

I have exactly the same experience with update 1.01 for Bartók. The device or software does not report the completion of the upgrade process. Bartok will not restart after the update is completed. This is very worrying because it is not known what to do, is the update in progress? or maybe it failed. The Mosaic App lost connection with Bartók at some point. The device was not visible on the network and did not respond to the buttons on the front panel. With a heart on my shoulder, I decided to turn off the device with the button on the back panel and this brought the device back to life :). I am asking you to improve the update process so that it becomes more friendly and less exciting.
Like the previous member I would like to receive information about the changes that the new firmware has brought.
Regards Robert Tota

1 Like

I did it also. And retapped check/install…

Voila! But it was a little scary … ))


The update process for the FPGA is fairly straightforward and I’m not sure why your units didn’t take the update on the first try. Under normal circumstances once the update file is downloaded, unpacked and verified (the status messages that show in the app) you’ll see a firmware update status on the unit’s front panel:

  • First a count down of the data transfer between the network board and the FPGA.
  • Then “UPDATING” with the progress bar
  • Then a message requesting that you restart the unit

The update process is very robust and the unit can lose power (or be switched off) without a negative impact EXCEPT when the “UPDATING” message with the progress bar is displayed.

If you don’t see update messages on the front panel after the app reports “FPGA update started…” then power cycle the unit and start over.

Version 1.0.1 contains some minor changes to the way in which memory is managed for settings storage and retrieval. It has no impact on the functionality of the unit, signal processing, or sound quality. If there was more to it than that we would have made a bigger deal out of it.

The update went smoothly here, as described :+1:t2:

Unfortunately, I have issues getting my unit updated, despite the usual process of power cycling the unit. At least the unit doesn’t get bricked.

I have tried a few times over the last couple of days; the app starts the download then reports ‘Error processing update. Please contact dCS’ - I rebooted the Bartok inbetween, no luck so far …

@AndyL and @Kevin_L,

Try this…

  1. Power cycle your units and wait for them to fully boot up
  2. Navigate to the update screen in the app and tap “Check for updates”
  3. When prompted tap “Install update”

What is critical here is to be sure that you are only tapping the buttons ONCE. A double tap at exactly the right interval can kick off two update processes simultaneously and get the unit into a weird state.

If that doesn’t work then we’ll need to get logs from your units and from those can figure out exactly where it’s failing.


Likely missing the link so need to ask…what is the problem this firmware attempts to solve? Are the update notes posted somewhere?

I answered this a few posts up…


Thanks Andrew that worked OK

Got it working through different steps, so I’m very pleased with the troubleshooting by Andrew.

After ‘Verifying Update’, it loses connection with the Bartok, and now I get ‘CHECKSUM’ on the Bartok screen. I had done a previous update but the unit could not reboot, so I rebooted manually but the update was not complete.

@Munchoba, If you have not already done so please power off your Bartók from the rear panel switch, wait 10 seconds, then power it back on and try the update again once the unit has fully booted.

The error you are getting suggests an issue with copying the image from the network card to the FPGA. This can happen occasionally and units typically update fine the second time around.

If you continue to see this error then please contact your dealer or distributor as your unit may require service. We’ll work with them to make sure that you are well taken care of.

Update worked perfectly using these instructions.

Hello @Andrew

After this update I encountered one more issue. Some times, after on/off Bartok I see that app does not show full detail info, after rebooting again it’s working fine. App issue is on iPad and iPhone.

One more thing… :frowning: