Mosaic Queue Issues

Am using the latest version of Mosaic with the Rossini. I create a queue in Mosaic picking songs that exist in a playlist (Tidal or Qobuz). Then I use the “Play from here” choice within the queue….I find that the queue order is not followed….many songs are just skipped.

Anybody else encounter this issue??

I hope that I understand what you are doing . You go to a pre-existing playlist on e.g. Qobuz. You then look through that playlist and select “Queue” for those tracks that you fancy hearing. You then go to one track in the Queue and select " Play From Here". Is that correct?

If so then that queue should play forward from the track to be played “from here” until the end of the last track in the queue. I have just tried it without any issues arising. NB: I use Vivaldi but, of course, Mosaic is identical to both Rossini and Vivaldi.

I cannot speak for Tidal as I am not a subscriber but there is one issue that can arise with some Qobuz playlists and which could cause your problem. Qobuz has a different music database for each of the countries it serves. The same playlists can nevertheless be posted the on all Qobuz territories’ servers. However if, say, the playlist was devised in France there is no guarantee that all of the tracks in it will be available in, say, the USA ( or vice versa). If you were in the USA and used the Qobuz Desktop Player to check the playlist you would see those tracks that are not available in that playlist for that territory are greyed out. However I am unaware of Mosaic being able to display this. So you might be unwittingly choosing to queue tracks that are not available to you in practice. I am not saying that is the cause of your issue but it is something that you need to be aware of.

Pete…thanks for the reply. When I play the same playlist using Roon as a player all of them play so its not a country scope thing. I note that Mosaic seems to skip songs at random. Am perplexed…z

Me too. I have tried to replicate your issue yet everything works fine. This type of issue did occur with earlier versions of Mosaic but even then was really about the creation of playlists not playing queued tracks. There are also issues of a similar nature related to incompatible UPnP software ( which will not be the case here) or network switch/router settings ( which may be) .

Pending someone with advanced network knowledge contributing to this thread one quick fix to try would be to re-install Mosaic on your device in case the version you have currently has become corrupted.

I just noticed from the “showing off” thread that you use an Innuos Statement. I am assuming that incoming internet music sources are routed through this to dCS? We have several reports of incompatibility between Innuos and Mosaic but, again, these relate to local files and the UPnP domain. However it may nevertheless be another area to investigate.