DCS Bridge not “seeing” Roon on my desktop

I have just received a Bridge on demo. The sound is fantastic but it will not “see” the Roon app on my desktop. It is seeing files on my NAS so it does not look like it is a network problem. Help, please!

Roon has to see your dCS network bridge first. Set up Roon properly through your desktop, to discover your NB.

In Roon (version 1.8) : choose Settings > Audio and if you see the dCS NB there (indicated under the tab Roon ready), enable it. If you do not see it there, then there is a network problem. I hope all your connections are through ethernet.

Maybe you like to read this topic from here:

1 Like

It should look like this in Roon.

Settings->Audio->Roon Ready devices (click on the koggwheel and choose enable).

Thanks for this - now enabled and flying! I will move the core to my NAS, too

Not all NAS works with Roon just a heads up before you move in that direction.

If you want to have a rather easy to build Roon server look at Roons ROCK solution that runs on a NUC.