Updated, but Mosaic no longer finds Bartok

Getting the Bartok recognized by Mosaic has always been iffy, but it has been working fairly well for quite a while now. Today, I did the firmware update (via Mosaic). Now, Mosaic does not find the Bartok. I have tried everything I can think of, including:

Cold and soft boot of Bartok
Unplug/replug every part of my wifi chain
Using two different wifi networks
Delete Mosaic and download again

The Bartok is on my ethernet network map and I can use it in Media Center. I just can’t get Mosaic to find it.


Have you tried updating the app?

If you mean by that deleting it from my iphone and downloading it again, then yes. I have no idea what version of the app I am using at it never gets beyond the looking for devices step.

It all worked well enough until the Bartok update.

Powered off/on phone/tablet? Same for any switches - changed the port the cable from Bartok goes in/swapped that cable?

Mosaic has always been a bit slow on the pickup after an update or power out/network change but crashing the App and starting it again, wait patiently and it has eventually settled down for me.

Did it all. Remember, the Bartok has not moved. Before the update it was running with mosaic. After the update it is not, though it does run with Jriver. Nothing has changed except that update

Try reserving an IP address for the Bartok’s MAC address in your Router/DHCP Server.

Pull cables, even overnight out of the Bartok.

Contacted Dealer or dCS Tech?

I’m not a technician, but I have one further suggestion: try to access the Bartók from any web browser on the same tablet as Mosaic. (Enter the IP adress in the browser. For me it’s: If the browser sees the Bartók and gets this page, I think you can be pretty assured that the problem is somewhere around Mosaic. If your browser (on the tablet, I insist) doesn’t see the Bartók, it looks more like a problem with your tablet. Here’s a screen cap of what you should have:

(You can get the IP adress from a network scanner like “IP Scanner” or “iNet Network Scanner”)

Yes, I can access the Bartok via ip on any device, including my iPhone and PC. I can use the Bartok from Jriver. Something is wrong with mosaic

Normally I would download the firmware again but the device tells me no update available so it thinks it is fine. Suppose I can find the file at dCS somewhere and redo from that

I am hoping someone at dCS is watching and has an easy fix

I had the problem, some time ago (2 years?), that my Network Bridge — or was it the Bartók? I don’t remember… — suddenly “disappeared from view” while playing in JRiver. Long story short: the culprit was a network switch (D-Link if I remember correctly). Everything else was working perfectly — general computing, internet access, data transfers, etc. — only this problem of dCS gears periodically disconnecting from the network. And it was cured by changing the network switch(es). So, I’d advise that you also check the signal path between your server and Bartók; and if there’s any network switch in between, try to remove it or to replace it with another brand. You never know… sometimes weird things happen in the computer world…

Hello? dCS?


I apologise that your request has not been picked up - we have just had a long holiday weekend here in the UK so we haven’t been keeping an eye on the forums.

For anyone’s future reference we do have a [email protected] email address that gets directly to me and our other support guys and will generally be a quicker way to contact us.

As you can access your Bartok via the web interface using its IP address then the unit is connected to the network so it seems like the autodiscovery isn’t being handled correctly.

Mosaic uses only properly documented protocols to do network discovery and so issues with Mosaic not finding devices always (in my experience) comes down to issues with the underlying network - often because of poorly performing ISP supplied kit (for example BT Homehubs in general have a really annoying trait of working fine for a while and then quietly start dropping multicast and unicast packets until they’re rebooted) …

What router are you using?

Are you using any kind of wireless extenders, wireless meshes or additional wireless access points to improve WiFi coverage?

Do you possibly have multiple routers in use in your network?

Is your Bartok connected directly to your router via a single CAT5e or CAT6a patch cable or are you using any Ethernet Over Powerline or Wireless Mesh extenders that you are plugging the Bartok’s Ethernet cable into?