Mosaic and Qobuz

Is there any way of Mosaic linking to my existing Qobuz favourites and Playlists?

I know I can add albums as favourites but this just creates a further separate list. And I can’t see any way to access my existing playlists

It should all be there in Mosaic without you needing to do anything. If you open Mosaic and select Qobuz you should then see a list of options including favourites and playlists. Any music held by your Qobuz account should automatically appear in the relevant Mosaic Qobuz option.

Unfortunately it’s not synching that. And more bizarrely there’s a load of albums that have never been in my Qobuz favourites!

OK this is very odd. Mosaic Qobuz is just a mirror of the titles that you have stored in your account on the Qobuz server. So the first thing to check is that what Qobuz has stored for you is what you think it is.

Do you have the Qobuz desktop app installed on your computer? If not install it, log in and open your account ( top right hand corner). Open Favourites and Playlists. Do you see what you expect?

I have been using the Qobuz desktop App on my computer until I started using the Bartok 10 days ago. I also use the Innuos Sense App on my 2nd system.

Both the Qobuz desktop App and the Innuos Sense App show my Favourites and Playlists correctly. Mosaic only shows Albums I’ve save in the last 10 days but also contains random albums I have no interest in. Playlists is completely empty.

Thanks David. OK so that eliminates Qobuz itself from your issue.

In most examples of this kind of problem the solution relates to the configuration of the router/network switch where the commands from Mosaic or the responses from the source are not being communicated properly. We have been in this general area before over the past weeks with your playback speed issue.

When streaming Qobuz are you connected directly to the internet e.g. Bartok network input connected directly to switch/router?

I can say that unless it has become corrupted in some way this is not a known Mosaic fault. It should work perfectly as it does for others and should provide all of the factors you instance that you are not getting currently. You may wish to simply reinstall Mosaic app on your phone/tablet to check if you are using a corrupted version. However I am not anticipating it will provide the answer but it is worthwhile checking.

If you are connected directly to the internet and your Mosaic app installation is stable and the problem persists hen I think that the next step is to ask you to provide details of the make and model of your router and/or network switch.

I’ll try re-installing. It would be a disappointing end if it turns out to be something related to a Network switch given Innuos Sense functions perfectly in the same set up

OK reloaded Mosaic with exactly the same result…

Sadly as I expected but still worth checking. So it is now most likely router / switch settings.

Have issues with Qobuz and Mosaic as well… Qobuz works with roon (dCS as endpoint), and Qobuz works with my app on mac (so it’s not an issue with Qobuz and credentials I guess). But it’s not possible to play my music from Qobuz via Mosaic app. Radio on Mosaic works…
Ah,…I see the albums in Mosaic (left side)- when clicking it on, it doesn’t play!

This isn’t a Router/Switch setting problem in David’s home, its a little more complicated than that I fear :persevere:

dCS/Mosaic interacts through the aggregation supplier, airable, for everything from album catalogs to list of favourite. It’s all referenced via airables (who has APIs into Qobuz for the actual information).

The dCS platform only start interacting directly with Qobuz once an album or track is selected for playback (and even then, it’s with Qobuz’ cache provider, like AWS CloudFront).

I suspect the difference David is seeing between the lists that he sees via Mosaic/Qobuz versus the native Qobuz App, has something to do with airables. I’m not experiencing any such problem though, so it’s somehow connected to David’s account on Qobuz maybe :thinking:

1 Like

Thanks. I agree I don’t think it’s a network problem as the Bartok is simply connected via a Cisco switch. One clue maybe that when connecting the Bartok I never had to sign in-it auto connected. That is in contrast to Innuos Sense where I had to supply my e mail /password after which Sense loaded everything correctly

Oh? Thats probably a good hint. You should maybe Logout from your Mosaic/Qobuz screen and login again.

1 Like

maybe Qobuz changed something? I have same issue- logout and logon again from Mosaic, didn’t work. Juancho has access to Qobuz via Innuos, I have access to Qobuz via roon- but not directly from Mosaic…

OK. Logging out and logging in has solved it for me! Great advice. But I don’t understand how it could connect to Qobuz without me logging in previously…

1 Like

That shouldn’t be the case, so something is off. :thinking:

Glad to hear it :+1:t2: :smiley:

No ideas on how/why you were able to access Mosaic/Qobuz without having logging in previously.

Thanky Anup- any idea?
I powered off dCS, powered off network, logout from qobuz, re-installed mosaic so far.

:thinking: What do you see from Mosaic when you try to access Qobuz albums or favourites?

I see the albums, favorites, purchased - they are all listed how it should be. Problem: when clicking on an album/track it doesn’t play.

I thought for a moment that you had found the solution!

As Juancho also seems to be reporting issues with Qobuz I wonder if Qobuz for your country or countries has done something? I was using the UK service last evening without any difficulty.

Is Mosaic showing an error message when the track fails to play?