Embedded covers not showing after minimserver update 2.1.2

Mosaic not showing embedded covers after minimserver 2.1.2 215 update
Cover is showed if it is only a folder.jpg in folder, but if it also has cover embedded in files (flac) it shows no image.
It worked in previous versions.
minimserver is installed in a QNAP TS 673
Mosaic is latest version.
Other apps (Esoteric, Linn, Teac, Lumin) don’t show that problem playing the same files (using a Linn device).

Hi Manel,

I’ve been trying to recreate your issue with the latest Mosaic and a fresh install of MinimServer 2.1.215 and I don’t seem to get any issues with browsing albums that don’t have folder.jpg files … could you possibly grab me some screenshots from your app showing the issue and email them to [email protected]?

Best Regards

Phil Harris

All folders have folder.jpg files.
The ones with only that file play OK, wit displayed cover.
The one with folder.jpg + embedded covers don’t.
I can see the small cover image (I guess it comes from the folder.jpg), but as soon as it beguins to play and reads the embedded cover, it goes grey:

It worked fine until very recently.

Manel, could be your iOS iCloud Private Relay setting, you’ll need to turn it OFF.

1 Like

It is already Off, thanks anyway.

No … neither the app nor the streamer have any visibility of the actual physical folder - the image data is provided by the UPnP server itself and the UPnP server SHOULD provide the cover art that is in the track tag as the primary source of the cover art for that track with the folder.jpg image (or whichever name and format the UPnP server supports as it isn’t rigidly defined) in the album folder only being used if the track doesn’t contain an image in its tag.

OK - so it is the “Now Playing” cover art that isn’t showing? I shall have a look at that tomorrow…

Best Regards


Hi Phil,
I’ll try to explain in detail.
I’m taking about minimserver the recommended one and the only one supported by dCS.

Mosaic reads both, the folder.jpg image URL that is sent by minimsrver and as soon as the actual flac file plays, it reads the embedded one, if there is one. If there is no cover embedded, Mosaic uses the folder.jpg image URL sent by minimserver.

In my case, if there is no cover embedded all goes fine with just the one taken from folder.jpg image URL.

Problem arises when both are present, then Mosaic can’t read the embedded one and fails to “ask” mininserver for the other one and it goes gray.

If I edit and remove embedded covers, all goes OK.

I have been using minimserver fo 10+ years, first issue so far.
I use navigation by folder

Thats good. Did you also check that iOS WiFi “Private IP” is turned off?

Both this and the iCloud Private Relay functions contributed to similar album cover art issues that you’re encountering - you’ll find them in previous posts here on dcs.community.

Hi Manel,

I’ve been running this here today with tracks with and without embedded artwork and with and without folder.jpg images and I cannot get Mosaic to do what you are reporting …

Do you have any other devices that you have Mosaic on? If so, do they exhibit the same issue?

What happens if you delete Mosaic (and any associated data) from your tablet and then reinstall it?

Best Regards

Phil Harris

Hi Phil,
iPad an iPhone, same in both.

I did, but playlist are still there.
anyway I have the same issu if I use iPhone.
I’ll try again anyway

Thanks for your support, I hope we get it fixed without having to remove coverd from 20.000 albums :scream:

Thanks for the info.
I disabled all 3, no luck

Problem solved!

Following Simon Nash (minimserver) directions:

I shut down QNAP, turned off dCS player and iPad.
Then I rebooted router (using router’s software) and got the connected devices map.
Then I turned on QNAP and waited for minimserver to be ready.
It appeared on the router’s map. Same IP as before, since it is fixed (only the NAS has a fixed IP).
Then I turned on dCS and it appeared with the same IP as before.
Finally, I started iPad and, of course it appeared, I can’t tell about previous IP.
… and embedded covers back online!

Everything is in the same place, I can see no differences, I have no idea on why and how, but it works!